: Fan blade upgrade



Naf
02-17-13, 04:51 AM
Which fan pulls more air, is it the 5 blade on the left or the 7 blade on the right?

I would like to upgrade the fan blades so i am coolin a bit more. Last yr my car was over tempin and i am goin through every thing to find out why, the rad was flushed several times and the headers wrapped. So far the only issue is the fan...

Lookin forward to your replies

HAMSTAR
02-17-13, 09:46 AM
Did you try a low temp thermostat an adjusted fan speeds via tune?

AAIIIC
02-17-13, 09:48 AM
What radiator do you have?

In what conditions was it "over tempin"?

crankedupforit
02-17-13, 09:48 AM
Naf? Is that you?

PISNUOFF
02-17-13, 10:01 AM
Naf? Is that you?

Hasn't burned up in the desert yet?

Naf, I think you need a radiator....for your radiator. I can develop one for you. It will only be $42,793.67. You can send a deposit for 1/2 that amount to my Paypal account.

darkman
02-17-13, 10:34 AM
Lose the underdrive pulley and get an Evans water pump.

Naf
02-18-13, 03:10 AM
I did take care of the fan speeds for my new thermostat...

I have the ron davis rad, and regular pulley.

The over temp happens at low speeds with or without the AC on.

Its fine at 185F as long as i am above 60mph, any speed lower and my temp climbs to 230F

I have the new LS3 waterpump

Evans waterpump is way too expensive, and the sellers wont deal with me for i am overseas...

rand49er
02-18-13, 10:43 AM
With all the unconventional mods you've done, I'd say it's hard to know what's going on. What ambient conditions?

HAMSTAR
02-18-13, 11:16 AM
Are you running a 160 or 180 tstat?

alradco
02-19-13, 01:08 AM
Are your fans on factory settings? What is your coolant/water mix? Ambient temps? We're slowly started working on a new dual fan kit for the CTS-V but really I'm not sure that there's much demand for the application.

Naf
02-19-13, 01:47 AM
Are you running a 160 or 180 tstat?

I am running a 180 stat


Are your fans on factory settings? What is your coolant/water mix? Ambient temps? We're slowly started working on a new dual fan kit for the CTS-V but really I'm not sure that there's much demand for the application.

I am running 180F settings, with 50/50 mix, will experiment with 33/67 coolant to water and see if that helps. I ordered both the 5 and the 7 blade fans, will experiment to see which is the best for my app.


With all the unconventional mods you've done, I'd say it's hard to know what's going on. What ambient conditions?

Ambient temps are below 70F, thats why i am very concerned. Something is wrong and it has to be with the cooling system...

650$ for the evans water pump, DAMN!!!

AAIIIC
02-19-13, 11:32 AM
I did take care of the fan speeds for my new thermostat...

I have the ron davis rad, and regular pulley.

The over temp happens at low speeds with or without the AC on.

Its fine at 185F as long as i am above 60mph, any speed lower and my temp climbs to 230F

I have the new LS3 waterpump

Evans waterpump is way too expensive, and the sellers wont deal with me for i am overseas...

Naf - There was a thread recently over on ls1tech about coolant temps. That site loads horribly slowly here at work, so I can't go there to find the link. It was a very interesting thread, because there are some folks whose coolant temps behave like yours, and some folks whose coolant temps stayed low even in stop and go traffic. There was no clear trend that I could see as far as modified vs stock.

With my first engine, I don't remember my coolant temps ever going high. Even at track events, they'd get up to the 210-220 or so, and would come down immediately once I got off track - and that was with all stock cooling components. But with LS6 #2, my experience is basically like yours - even with a big radiator (Alradco in my case) and a cooler t-stat my temps will climb up into the upper 220s or low 230s. In my case, the breakpoint seems to be around 45mph. I don't understand it, but that thread on ls1tech showed that I (we) are not alone.

As for the Evans pump, are you sure it will even fit? When I was doing some searching for a pump recently, all the water pumps I could find were of the taller variety. Even Evans "short" pump will almost certainly not clear your fans with the thicker Ron Davis radiator. I have some pics and measurements at home, I'll try to remember to upload them later.

darkman
02-19-13, 12:07 PM
This is a long shot but if you want to be absolutely sure your are not getting steam pockets in the system you could open the vents on the rear of the heads. Those vents used to be connected with tubing on LS1s, but are simply plugged on the LS6 based on the theory that the front vents sit higher than the rear and should be sufficient. Kurt Urban makes a kit for this, but it could be implemented with separately purchased components. http://www.kurturbanperformance.com/ls-water-vapor-system.html

Andringa
02-19-13, 12:59 PM
Not trying to be a smart ass, but sometimes we forget to check the simple things.

Are the fans working? Any possibility that the tune is accidentally turning them off?

If the cooling system works fine at speed it seems to me that the issue is with the amount of air moving through the radiator, not an internal issue. Hope you get it figured out.

HAMSTAR
02-19-13, 01:08 PM
Not trying to be a smart ass, but sometimes we forget to check the simple things.

Are the fans working? Any possibility that the tune is accidentally turning them off?

If the cooling system works fine at speed it seems to me that the issue is with the amount of air moving through the radiator, not an internal issue. Hope you get it figured out.

I'm with this guy.

Naf
02-20-13, 06:22 AM
The fans are setup for a 180 stat so i dont burn them out, once in motion the rad should cool it self to 160.

I will look into the Water vapor system first. its only a couple hundred bucks.

That might be my problem with the High Compression heads and ported too. so there is no meat to protect the water from boilin over...

I will test my fans with the rad installed and see which combo produces the most airflow...

The Evans WP will fit with my rad, i got confirmation of that from Nate

so spend 200$ now then if it doesnt work spend 650$ later. then pray it all works

trukk
02-20-13, 03:05 PM
Did you grind the welds on your radiator, and cause a hole?

I would get the 11 Bladed fan.

104168

-Chris

rand49er
02-20-13, 03:39 PM
^^^ Ah-h ... Spinal Tap. One of my favorite flicks.

trukk
02-20-13, 05:38 PM
^^^ Ah-h ... Spinal Tap. One of my favorite flicks.

Makes me sad that my age is probably closer to your old azz than most of the new folks around here :D

At least Naf is still around to keep it fun.

-Chris

AAIIIC
02-24-13, 10:50 PM
Naf - There was a thread recently over on ls1tech about coolant temps. That site loads horribly slowly here at work, so I can't go there to find the link. It was a very interesting thread, because there are some folks whose coolant temps behave like yours, and some folks whose coolant temps stayed low even in stop and go traffic. There was no clear trend that I could see as far as modified vs stock.
Naf, here is the thread (http://ls1tech.com/forums/cadillac-cts-v/1607003-post-your-engine-coolant-temps.html) over on ls1tech that I was thinking of.


The Evans WP will fit with my rad, i got confirmation of that from Nate

This thread (http://ls1tech.com/forums/cadillac-cts-v/1582487-oem-vs-gm-performance-water-pump.html) has information about the water pump options, including the Evans pumps. Based on phone and email conversation with one of their engineering types, even their "short" pump would protrude about 1/2" or more into the fan shroud with my Alradco radiator and the stock fans. I would imagine the Ron Davis radiator has similar dimensions.

Naf
03-06-13, 07:24 AM
i went with the 5 blade rather than the 7 blade. At full power the 5 pulls more air then the 7 when connected to the radiator.

Waiting on my oil pan to be modified to fit then will start my rebuild process.

Waiting on custom wire sets only.

stever06
07-26-13, 12:35 PM
Hey Naf wondering how the 5 blade fan worked. I am having the same exact cooling issues that you describe. Its driving me crazy and I haven't even began to really modify the car yet. Still working out the bugs and the cooling issue sucks. The car is in really good shape and was well cared for just the usual v issues.

jamesdem1123
07-26-13, 08:31 PM
Mine used to run pretty warm, then I switched to a 165 degree thermostat and a 20/80 coolant-water ratio and a couple bottles of water wetter.