: Car thinks fob is inside when its not.



Scoobie
02-16-13, 12:22 PM
Wondering if I have a problem. I have a 2012 SRX with only one key fob(bought it used and was only provided 1). Almost every other time I get out of my car, it honks 3 times when I shut the door. I know that's the reminder that I've left the fob in the car...but the fob is in my pocket, not in the car. Its at the point where I try to be as far away as possible before shutting the door....imagine how odd that looks, stepping 2 metres away then using your fingertips to swing the door closed. Forget about doing this in parking lots where you only have 1-2 feet between cars. Because the car thinks the fob is inside, it won't remote start. The second fob is not in the car, I've tested that theory by trying to start the car while my fob is in the house. It displays "no remote detected".The dealer says the sensors are functioning properly. Does anyone else have a similar issue? Or should I go back to dealer and insist on checking the sensors again.

RippyPartsDept
02-16-13, 12:25 PM
try this... leave your key far away from the SRX ... get in the SRX and try and start it

the proximity radios that sense if the key is in the vehicle can tell if you're in or out of the car so there's no need to do that awkward door shutting procedure

i think there's a key in the car somewhere

Scoobie
02-16-13, 12:32 PM
I tried that. It say " no remote detected".

RippyPartsDept
02-16-13, 12:35 PM
ok then the radios are malfunctioning and you're going to need the dealer to fix it for you

try and get someone else to hold the keyfob outside the car and take one step away each time you try to start it and see how far exactly you have to get before it doesn't recognize the keyfob

that way you can at least let your dealer know as much info as possible

i've never heard of this before but it sounds like it could be something as simple as a reflash/reprogramming of a module or it could turn into a big headache

good luck

Scoobie
02-16-13, 12:45 PM
Just tried that. Once it wouldn't start when the fob was about 1 foot away- it said "no remote detected". Then it started when the fob was 3 feet away but it said "no remote detected" & "press brake to start". Then it wouldn't start when the fob was 4 feet away. No consistency.

RippyPartsDept
02-16-13, 12:47 PM
yeah that's going to be a dealer fix

it shouldn't detect the fob when you close the door normal

Scoobie
02-16-13, 12:49 PM
Ok thanks Chris. I'll go back and insist on a more thorough check.

RippyPartsDept
02-16-13, 01:50 PM
if you can demonstrate it to them that will get the point across best

Cadillac Cust Svc
02-18-13, 12:23 PM
Scoobie, I'm happy to see Rippy (Chris) was able to assist you this weekend and provide insight to your concerns! Please keep us updated on your dealership trip results, and don't hesitate to get in touch with me if you would like Customer Service to step in and follow up with your dealer at any point on your behalf. (I'm reachable via email at Katie_Lucille@gmexpert.com!)

Best,

Katie
Cadillac Customer Service