: DTS sunroof stuck open



Lev Blekher
02-12-13, 11:29 AM
Hello everyone. Long time no post.

Yesterday I ran into a problem with my 2006 DTS where the sunroof would not close. When I pressed the close button, it would start to close, stop halfway, then retract a little bit. The other button, for tilt open, did not do anything. It was drizzling on and off all day and I am quite busy the rest of the week, so I decided to drive the car to my parent's house. They are out of town for a while so I was going to leave the car in the garage and take on of theirs and let them take it to the dealer. Well after a 3.5 hour trip, just as I pulled into the driveway, I pressed the button to close the sunroof and it closed. However, this occurred after pressing the button that normally would not close it from full open position (the vent button).

The strange thing is I pressed the buttons a few times during the trip and it still did not close. What it was not: I checked the tracks and everything underneath the headliner (turns out you can pull the headliner down a bit because it is held up by a magnet right behind the sunroof opening) and there were no obstructions. Everything seemed well-lubricated. I tried a cycle of shutting the car off, locking the doors, unlocking, and turning it back on and that didn't work. I searched online and found some reset procedures for other cars and GMs but nothing worked, and I could find no help for this issue with the DTS specifically either. I called a dealer service manager I know well and he told me he has never seen this in a DTS and there is no manual close for the sunroof. The fuse was fine too.

The main clue in this is what happened when I got home: I randomly decided to press the button that only tilts the sunroof up and down, and that button actually closed the sunroof all the way. But as you know in the DTS if it is fully open you must close it with the button that opens and closes it, not the vent button. After this the sunroof worked as normal. This leads me to believe that there was a short circuit, possibly due to corrosion.

I am currently not going to use the sunroof but I normally have my sunroof open on virtually any drive I take, even in the winter or during a slight drizzle in which case I tilt it up, so this is quite disconcerting. I plan to have the dealer inspect it and replace the entire wiring system unless we can come up with some other cause. If I have the patience to wait until I have free time, I might do this repair myself (have several years of car work experience). Thanks for any help!

Cadillacman916
07-29-13, 06:52 PM
I have has the same problem in my 07 dts. After it closed using the vent button it has worked normally for the last few months... figured the computer freaked out and reset itself

Superjim
07-29-13, 07:48 PM
Now that y'all are talking about it... I "THINK" I have had mine not close using the "NORMAL" close button...
I pushed the other one and it closed.
I didn't think much about it and didn't really pay that much attention to it.
I was just kinda thinking I had pushed the wrong button to try to close it.

It has happened two or three times in the last 3 years or so...
If it happens again... I will pay more attention to the buttons and report back.

Cadillac Cust Svc
07-30-13, 11:07 AM
I have has the same problem in my 07 dts. After it closed using the vent button it has worked normally for the last few months... figured the computer freaked out and reset itself

Hello Cadillacman916,

I apologize for any trouble you had with your sunroof in your DTS. I am happy it is functioning normally for you now. If there are ever concerns or questions you may have, don't hesitate to reach out to us via private message so we can help!

Sincerely,

Laura M.
Cadillac Customer Care