: climate control not functioning/ passenger side heated seat wont shut off/



wyse18
01-31-13, 08:15 PM
climate control not functioning/ passenger side heated seat wont shut off/ stee

----------

I had the heatercore replaced by someone who was not competent enough to put the car back together the right way. Now my climate control will not function, the passenger side heated seat will not shut off and and the dash lights will not turn on, the fog light button turns on and off the headlghts instead of the headlight switch. I was told that it might be the body control module but I'm not really sure what to think. I dropped a bunch of money on this and got my car back with a misaligned steering wheel and all of these problems. These are only a few of the problems that I have now. Most of the problems.except for the steering wheel are electrical and I have no idea what could be wrong. If anyone could point me in the right direction for repairs I would appreciate it. Thanks in advance. My cars electrics were in good working order before this and because of this I havnt been.able to drive it in months. Thanks for reading.

kaustein
01-31-13, 08:45 PM
From experience the car is an electrical nightmare! My sunroof would open and close at will! Memory seats would try to fold me in half. Fog lights a mind of there own. But the worst was when I couldn't turn the passenger side fresh air inlet off in the dead of winter. Driver side I roasted, passenger side, my wife was wrapped in a blanket.

Finding competent people to work on it is very difficult. I've a Caddy dealer owner state that they didn't even want to see them in the shop.

hgqguy
02-05-13, 04:25 PM
Man... thats so unfortunant. I have had sever people say the EXACT same thing.. went in for heater core came back witht he same issue! It just sounds as if it was not assembled properly.. your seat heaters are prolly not connected.. you can disconnect them under the seat.

Id pull the dash aport and work on it myself! Im sure you will find stuff not connected!

wyse18
02-06-13, 03:35 PM
I know eh it sucks big time. I will end up taking the dash apart and figuring it out, I have done some minor electrical work on the car, like replacing the K134 module and replacing the instrument panel light bulbs with blue led's but never even have gotten a chance to drive with them in because shortly after I installed them I went for the heater core replacement and now its F'd. Im taking automotive collision repair and refinishing where Im from (Nova Scotia, Canada) and hope we will be getting into some electrical type work so I can gain some confidence in it.
Thanks for the reply and for letting me know that I'm not the first person to encounter this type of Fubar.

kaustein
02-06-13, 05:15 PM
The car is brutal. It is always one thing after another.

arten11
08-10-13, 05:00 PM
gear on motor is disengaged put a washer to space it out check the motor if is engaging when you push the button.