: Tcs issue, and bumper fitment question...



IvoryWhiteCatera
01-26-13, 06:05 PM
My 98 Catera is running well since its last minor overhaul, but I'm in the dead middle of winter and my TCS isn't working. When I start skidding the TCS flashes and stays on. I try pressing the button to turn it back on to no avail and my tires keep spinning. Any ideas?

And I'm looking to buy an Opel omega bumper. Does anyone have any idea if the fitment will be off? I know we have stricter crash safety laws and our bumpers protrude more than the Omegas...

Thanks.

investor74
01-26-13, 10:48 PM
The TCS button on the dash actually turns off the TCS, not turn it on. The default is the TCS is on. If the TCS light is flashing, it means that the TCS has detected a wheel is spinning and is reducing the torque to the wheels. If you hit the button at that time, you turn off the TCS action. If the TCS light comes on solid, there is a problem with the TCS system which is closely related to the ABS system.

elvin315
01-28-13, 12:46 AM
Not sure about te bumper cover but here's a link to the Omega Owners Forum re: removing their cover.
http://www.omegaowners.com/forum/index.php?topic=90683.0

Please respect their copyright and read their rules.

IvoryWhiteCatera
01-29-13, 11:31 PM
Thanks. And I am aware that a solid light means off. But mine goes solid when my wheels spin, although I didn't press it.

MoistCabbage
01-30-13, 02:14 PM
Your wheels spin, the system activates, realizes there's a problem, sets a code, and turns the light on.

You have to have your codes pulled.

IvoryWhiteCatera
01-31-13, 01:06 AM
Cool thanks. Is there like a sensor or module that I would need to replace?

MoistCabbage
01-31-13, 02:09 AM
That's what pulling the codes will tell you.

AutoZone will pull the codes for you for free. Just don't listen to the employee when he tries to tell you how to fix it. Post the code/s and definition/s here.

IvoryWhiteCatera
02-07-13, 03:01 AM
Thanks will do.