: Injector



Aaron79
01-22-13, 03:15 PM
I have a 2005 V6 STS the computer code is reading misfire in injector #4. I have changed the plug and coil pack with no change in how the car is running. Can you provide any guidance on what else it may be.

dkozloski
01-22-13, 04:08 PM
Why are you working on the ignition system when the trouble is in the fuel injection system?

Aaron79
01-22-13, 04:31 PM
What should I be looking at to fix this?

orange57
01-22-13, 04:56 PM
The fuel injector.

Aaron79
01-22-13, 04:58 PM
Do you know where that is located on the 05?

orange57
01-22-13, 11:39 PM
I don't know if the V6 is a direct injection engine or not, but I do not believe that it is. Therefore, I would suspect your fuel injectors are installed in your intake manifold. Remove the engine cover, and there will probably be a tag on the fuel that says something about the line being under fuel pressure. That fuel line would be connected to the fuel rail that would then split off to the six injectors. Each injector should have a plug on it. Remove the engine cover and with the car idling you will probably hear them clicking.

----------

Also, the CTS used the same engine, so it may be worth searching the CTS forum as well. Since there are more CTS produced it may have a higher chance of someone doing this same fix over there.

2005 CTS had around 61,000 Cars produced, where as the 2005 STS had around 33,000. And the STS numbers was all V6 and V8. Not sure the individual numbers for the engines in the STS

EChas3
01-23-13, 10:59 PM
2008 STS & later were DI.

orange57
01-23-13, 11:21 PM
After I responded I looked it up and found that out. I knew it went to DI, just wasn't sure when.