: P0121 P0221 and P0101 codes



kanundrum
01-16-13, 11:43 PM
P0121 P0221 and P0101 codes
Got all these Codes, I have had the MAF code before so I am thinking its a bad MAF just wondering if the MAF would throw those codes as well or its something more in depth I should look at with the Throttle position Sensor

2.8T Motor

http://www.obd-codes.com/p0121

http://engine-codes.com/p0221.html

Any Hints or should I start by replacing the MAF and the TPS(Not even sure where that is) MAF was cheap enough that I ordered a new one

TheCaptain
01-17-13, 08:12 PM
It's most likely the MAF. Its also easy enough to start there (which you have).
I bet a new MAF will fix all three. (chain reaction codes)

kanundrum
01-17-13, 09:18 PM
Awesome Thanks yea getting the new MAF in tom so lets see. The K&N Probably messed it up, or it was already messed up and the K&N didn't help. Just a simple drop in filter too

TheCaptain
01-18-13, 08:18 AM
I have seen these codes thrown a lot on GM vehicles with a dirty MAF. Most usually from K & N filters... :o

Jim_V
01-18-13, 03:36 PM
I have a K&N also and just spray electrical contact cleaner to eliminate any problems. Just don't touch the sensor wire let the spray do the work.

kanundrum
01-18-13, 04:44 PM
I have a K&N also and just spray electrical contact cleaner to eliminate any problems. Just don't touch the sensor wire let the spray do the work.

DId it about 3 times now, I just got the MAF in will clear the codes replace the part and see how it starts up!

redvett94
01-18-13, 05:18 PM
When you get it fixed throw the K & N in the trash and use a paper filter for better filtering. Paper filters are good for 30000-50000 miles and will NOT reduce fuel economy since the engine management system will always keep the A/F ratio at 14.7. If you drive in high dusty conditions you may want to replace filter earlier.

kanundrum
01-18-13, 06:26 PM
Was never looking for fuel economy, more power was always my goal. Even though it maybe hard to believe, the difference with the K&N was massive. Could hear the Turbo Spool up and a noticeable amount of power, but probably also the reason why I got the Codes. Never had an issue on any other car !

kanundrum
01-21-13, 11:42 PM
Changed the MAF and got the code on again after, weird installed a brand new filter and MAF and got the P0101 code (not the others). Lets see what happens

kanundrum
01-23-13, 11:37 AM
So the first time the CEL came on I got P0101, now the 2nd time I got P0121. The car is screwing with me! haha. This is even after I changed the MAF to a brand new Unit. Any ideas Folks ?