: Weird issue



98Geldog
01-15-13, 11:15 AM
2 days in a row now I was driving the cat. Stoped ran in the store real quick came out and when I start it up it takes about 5 seconds to start. Then the car idles over 2000 rpm and stays there till I pull of snd then everything's fine. Does it sound like the throttle is being stuck open. If so does it explained the sudden valve cover leak?

cateralover1209
01-20-13, 02:53 PM
you may have massive vacum leak a bad mass airflow a bad coolant sensor a plugged crank case ventilation box just do research on these most common idle issues in the cateras

elbrown4183
02-09-13, 03:17 AM
..Or Idle Air Control Valve.

retho78
02-09-13, 07:47 AM
Did u do take out the throttle body while working on it recently? If so, try to let the throttle relearn it by following the relearn steps.

If not then it could be vacuum leak or MAF.

98Geldog
02-09-13, 08:01 AM
Well I've changed the MAF And temp sensor twice cleaned the breather twice and changed the valve cover gaskets and replaced the breather box hoses. The problem seemed to go away for now but the valve covers still leak. The box that sits in front of the fan that connects to the TB what is that called? It has a oil and coolant mix in it just a little from the old engine. I will thoroughly clean that out today as every time I check the black box on the top of the engine the tubes have that residue in them

98Geldog
02-24-13, 04:47 PM
Well I think I found the problem. Was driving home on the expressway yesterday and of a sudden POW, the started to pop like a racing car would and I couldn't excelerate more than 30mph there's my massive vacuum leak. Passenger side manifold . Anybody ever had this problem?