: Bank 1 sensor 1



98Geldog
01-08-13, 01:31 AM
I got code 0135 and 0115 o2 sensor bank. 1 sensor 1 and coolant temp sensor circuit . Changed temp sensor code still there. My question is bank 1 sensor 1 is the right side before the cat. Is this a upstream or downstream sensor? I'm going to by it from rockauto and need to know exactly what I'm getting. Thanks for any info.

98Geldog
01-08-13, 04:08 PM
Ok I don't get it. I replaced both of these sensors, erased the codes and they still come back like right away. They were the correct parts because they are exact from the ones removed. All connections look good from what I can see. What could be the issue? I have a 2000 body but a 1999 engine. Does the computer look for something different from the two years or what. Please help

Oh by the way the car runs perfect. But this service engine light is very annoying

JohnJJO
01-09-13, 07:14 AM
how do u erase the codes

98Geldog
01-09-13, 10:54 AM
ODB2 scanner take it to autozone they'll do it for free

olddavid
01-09-13, 01:45 PM
I went through a similar stretch sometime back. I finally managed to clear my light by cleaning the contacts on the MAF plug. How much for the sensors in Chicagoland?

98Geldog
01-09-13, 02:27 PM
Expensive about $260. Me personally I went to the none yard and the two cat that were out there I pulled the MAF but not luck. But I will try cleaning the connector.

nethic
01-10-13, 03:43 PM
If doing regular maintenance of the exhaust system, what would you change first, downstream o2 sensors or upstream o2 sensors (front ones first or back ones first) ? and how does it matter?

MoistCabbage
01-10-13, 05:34 PM
O2 sensors are part of the emissions system, not the exhaust system. "Regular maintenance" does not apply to O2 sensors, they either work, or they don't. If there's a problem with an O2 sensor, a code will set,and the CEL will illuminate.

98Geldog
01-11-13, 02:21 PM
O2 sensor code went away. Coolant temp sensor reading 280 should be around 220. Small leak in the radiator, someone put JB weld on it. 300+ bucks just for the radiator!

nethic
01-11-13, 05:36 PM
O2 sensor code went away. Coolant temp sensor reading 280 should be around 220. Small leak in the radiator, someone put JB weld on it. 300+ bucks just for the radiator!

I think I seen a couple on ebay for less then that. let me see if I can find them and post them here for you