: CUE issues with NAV location not changing



pkadanec
01-07-13, 04:21 PM
So, let me see if I can explain this anomaly... If you attempt to enter an address or POI the NAV will default to the last location that you were in when you entered a selection. For example; Say I am in Charlotte, NC and i look up Bob's Steak House. Then I drive to Atlanta. I try to look up say, Buckhead Saloon. The NAV still thinks I am in Charlotte, NC. They way it SHOULD work is that the default should be my current location and I should have to actually either say "change location" if using a verbal command or actually type in the city and state with the address. Not sure that makes sense or not. Would appreciate someone from Cadillac responding.

Paul

codeman71
01-08-13, 04:20 PM
Hi Paul, thanks so much for writing here. It is supposed to work exactly as you are expecting, always defaulting to your current location, unless you specify otherwise.

So you are trying to do a search for Buckhead Saloon using voice? Unfortunately, it looks like Buckhead Saloon is not a location that the system will be able to recognize by voice. It is set up to recognize large chains that are nationwide. If you are looking for this using speech, you would have to use a category name, such as Restaurant, or Steakhouse.

If you were to type this into the POI search keyboard, it should find it no problem when you are in Atlanta without having to do anything ahead of time. It shouldn't keep searching near Charlotte.

If you happen to give me any more details like if you had a route running already, or if you just tried voice or if you also tried using the touchscreen keyboard, that would help me in figuring out what exactly the issue is that's going on.

If you are entering in an address using the keyboard, it will by default look in the current state you are in. So if you were in Atlanta (or anywhere in Georgia) you could just type in "3227 Roswell" and it would find any matches for that address and give them to you in order by distance from the car. Or, if you give it more specific information like "3227 Roswell Atlanta" or "3227 Roswell 30305" it should then find a more exact match. It tries to fill in any blanks you give it with information about where you are. But again if it's somehow staying in North Carolina, then there's a definite bug.

Thanks again for writing about the issue!

pkadanec
01-08-13, 05:08 PM
Thanks for the reply. To your first question, i was just using those as examples, not actual searches.

In both of our examples, entering as a keyboard address or using a voice command it will always default to your last search location, no matter where you presently are located.

I discovered a similar bug when trying to search in another city and state for a particular hotel. It would always return the current location. This only seemed to occur when using voice. If you typed the POI with city and state, it would bring up the correct list of choices, but never with a voice search.

I was searching for Hilton-Greenville- North Carolina. I would get the correct voice nav response, but as soon as it said, "when it is safe to do so...blah blah blah, select your choice from the list on the screen" The problem is that the list was only hotels from the current location.

Now the "feature" that i described in the previous thread occurs. It never defaults to the current location. If i were to use the above as an example, now if i were to search for say Hilton and i am currently in Charlotte, NC I would get a list of Hotels that matched Hilton for Greenville NC, NOT Charlotte.

It is very odd, because the expected behavior is exactly opposite of what you would expect to occur.

BTW I have taken it to the dealer and they stare at me like deer in headlights....

codeman71
01-09-13, 09:48 AM
Yeah, there were some bugs that I found related to specifying a search location by voice and those have been fixed in some newer software that I tested, so it should be fixed soon with a software update when it is released.

Yeah, the dealers are in a tough situation right now because we haven't released any major software updates as of yet so there's not much they can do right now. Hopefully once we send out the first update they will have a bit more knowledge about what they can do for bugs like that.

I'll try some more testing with the new software to see if I can get that to happen, but more than likely it's been resolved as well.

Thanks again for your help with the bug.

pkadanec
01-09-13, 09:56 AM
Thanks, codeman71! Please keep me posted. Do you have a tentative release date estimate?