: Nav Defaults to Washington DC



floridaguy
01-05-13, 10:03 PM
After searching this forum, I see that 2010 models had the problem where the Navigation System would default to Washington D.C. I have a 2012, and today I attempted to enter a destination, but first I had to agree to some legal declaration, then it had me in Washington, D.C. so I had to change it back to Florida. I guess it's not only 2010 models with this problem. I saw that folks that had this problem also had an issue with the clock. I need to check that and see if that is also an issue. It seems the fix was a firmware update.

stevec5375
01-06-13, 08:58 AM
After searching this forum, I see that 2010 models had the problem where the Navigation System would default to Washington D.C. I have a 2012, and today I attempted to enter a destination, but first I had to agree to some legal declaration, then it had me in Washington, D.C. so I had to change it back to Florida. I guess it's not only 2010 models with this problem. I saw that folks that had this problem also had an issue with the clock. I need to check that and see if that is also an issue. It seems the fix was a firmware update.

In some cases it's a firmware fix. I had to have my Nav/Radio unit replaced twice to have the problem fixed! It looks like after 3 years GM still has not squashed these bugs. Amazing! Head on over to the CUE forum and you will find that they have simply swapped one set of problems for another.

Ponyman
01-06-13, 11:39 AM
Actually after having our 2013 for almost two months, CUE is working very well. At least the features of it that we use.

floridaguy
01-06-13, 12:28 PM
I checked the clock this morning and it has the correct time. I also tried to enter a destination in the NAV system and all appeared normal. I'll keep an eye on it. Hopefully it won't happen again.

sube5186
01-06-13, 01:58 PM
I checked the clock this morning and it has the correct time. I also tried to enter a destination in the NAV system and all appeared normal. I'll keep an eye on it. Hopefully it won't happen again.

I hate to disappoint you, but if the Nav default thing happened just once, it will continue to happen until you get the firmware update. I may be sporadic, but it will continue to happen. You may never have the clock issue along with the Nav problem. I wouldn't make a specific service visit for just this. It's more of a nuisance than anything else. Get the update the next time you're in for something else.


Sube

floridaguy
01-06-13, 02:48 PM
I hate to disappoint you, but if the Nav default thing happened just once, it will continue to happen until you get the firmware update. I may be sporadic, but it will continue to happen. You may never have the clock issue along with the Nav problem. I wouldn't make a specific service visit for just this. It's more of a nuisance than anything else. Get the update the next time you're in for something else.
Sube

Thanks Sube, It's on my list of things to do.

Cadillac Cust Svc
01-06-13, 08:17 PM
Thanks Sube, It's on my list of things to do.

Floridaguy, I just wanted to let you know I'm here to help if you would like any assistance working with your dealer. Email me anytime at Katie_Lucille@gmexpert.com, and I can contact them on your behalf to schedule an appointment or follow up on concerns for you!

Katie
Cadillac Customer Service

floridaguy
01-06-13, 08:32 PM
Thanks Katie.