: tire pressure sensor monitor



phattruk
12-28-12, 11:22 AM
does anyone know where the tpms sensor is located. i have an '04 escalade. the indicator showinfg a flat tire is on the dash. i run 22's which are not original and have never had sensors in them so i know it's not a bad tire sensor. i believe it's the actual module that monitors these sensors. where would that sensor be and where can i find a replacement. i do a search but only the tire sensors themselves appear.

the cadillac man
12-28-12, 12:47 PM
does anyone know where the tpms sensor is located. i have an '04 escalade. the indicator showinfg a flat tire is on the dash. i run 22's which are not original and have never had sensors in them so i know it's not a bad tire sensor. i believe it's the actual module that monitors these sensors. where would that sensor be and where can i find a replacement. i do a search but only the tire sensors themselves appear.

They are built in the valve stems it sounds as if one them has died due to the battery

phattruk
12-28-12, 01:42 PM
I DO NOT have the original tires and tire pressure monitors on this truck, so it cannot be a tire sensor itself. . I have had aftermarket rims and wheels with no sensors for over 8 years. i always get message "service tire monitor" in the DIC and clear that every time i start the truck. I now have the flat tire indicator on the dash. this won't go away. it tells me the the sensor that reads the tpms's is bad. i need to know where this module is
located

the cadillac man
12-28-12, 04:01 PM
I DO NOT have the original tires and tire pressure monitors on this truck, so it cannot be a tire sensor itself. . I have had aftermarket rims and wheels with no sensors for over 8 years. i always get message "service tire monitor" in the DIC and clear that every time i start the truck. I now have the flat tire indicator on the dash. this won't go away. it tells me the the sensor that reads the tpms's is bad. i need to know where this module is
located

The service tire monitor is showing because of no sensors in the rims just get the sensors it is cheaper on eBay and you don't have to tear apart the truck to remove anything.

In order to install the sensors you would need the tires uncounted from the rims and they go in place of the old valve stems in the rims
Not sure if it would have be reprogrammed or you can just relearn them by the letting air out of each tire(I guess the later)I have a 03 which doesn't have this feature(the rpo code is also programmed in the tbc also)

FYI the tpms is built into the passenger door module which also works the keyless entry and passenger side mirror along with the window(obviously) and locks also makes sure the sensors are for a 04-06 not 07 and newer as the modules are different between the body styles

phattruk
12-28-12, 04:34 PM
cadillac man thanks. my mistake in the message appearing on the dic. its "check tire pressure". this started about 2 months ago along with the flat tire display which does clear from the dashboard. . I used to get the msg "service tire monitor" and that was because i do not have sensors in the tires. i have not had sensors on this truck since i got it brand new because i swapped out the stock tires for after market tires and never installed tire sensors. i'm familiar with the relearning as i have another gm vehicle wuth the same setup

wesyder
12-28-12, 05:35 PM
cadillac man thanks. my mistake in the message appearing on the dic. its "check tire pressure". this started about 2 months ago along with the flat tire display which does clear from the dashboard. . I used to get the msg "service tire monitor" and that was because i do not have sensors in the tires. i have not had sensors on this truck since i got it brand new because i swapped out the stock tires for after market tires and never installed tire sensors. i'm familiar with the relearning as i have another gm vehicle wuth the same setup

Ive had aftermarket wheels with no sensors with service tire mon sys light, then put the stocks back with sensors all ok then back to aftermarkets with flat tire light on, i don't know why the different messages, so eventually the sensors are going back in

the cadillac man
12-29-12, 01:18 AM
Ive had aftermarket wheels with no sensors with service tire mon sys light, then put the stocks back with sensors all ok then back to aftermarkets with flat tire light on, i don't know why the different messages, so eventually the sensors are going back in

The system goes nutty.

caddy2005
01-02-13, 07:04 PM
I have a 2005 sts where is the modual for the tire pressuring montering system located

the cadillac man
01-02-13, 07:30 PM
I have a 2005 sts where is the modual for the tire pressuring montering system located

Wrong section.

kims caddy
01-03-13, 02:53 PM
Light now the tire system monitor is on the dash. When I scroll thru it shows pressure in all tires to be at 35 but the right front shows -- dashes. I took it to a tire shop to see if I had a nail or something and they said tires are all good. Must be the sensor is out. Is there a way to reset? I'm trying to save a trip to thr dealership.

Sorry it didn't post the first of my ?? After the low tire pressure light came on and I added air and lights went off. Next time I get in car the other light is on for the system.

the cadillac man
01-03-13, 06:32 PM
Light now the tire system monitor is on the dash. When I scroll thru it shows pressure in all tires to be at 35 but the right front shows -- dashes. I took it to a tire shop to see if I had a nail or something and they said tires are all good. Must be the sensor is out. Is there a way to reset? I'm trying to save a trip to thr dealership.

Sorry it didn't post the first of my ?? After the low tire pressure light came on and I added air and lights went off. Next time I get in car the other light is on for the system.

Sounds like something isn't right in the system