: Hey .2000 escalade heater control does not work at all,hard to start when really cold



escaladeboss
12-27-12, 02:39 PM
Hey everyone its been a while since i posted/been on here,anyway here"s my problem....
1. My heater control only worked on hi or the the 3rd heater option for over a year but didnt bother me so i kept it like that(unfortunately)
until it was coming on and slowly started squaling making a crazy noise then i would shut it off on and did it for a while then suddenly it like burned out and had a smell and does not work at all..??????
Btw its like 20degrees out now usually so my truck is a ice box lol

2.my truck is hard to start in the cold like when its those 20 degree days...can start on the 1st,2nd,3rd 4th,or 5th turn..but heres 1 thing i noticed happened to me about 3 times when gas is too low truck wont start..until you add gas (ex.2 gallons) and it take around 10 on and off key turns to pickup gas...now i never let it get below 1/4 tank
fuel pump?

Fuel pump?
..btw i have new spark plug wires,sparkplugs,had ignition cap and rotor ,air filter,fuel filter done in march of this year (3/12)...

Thanks for all input

the cadillac man
12-27-12, 03:29 PM
Hey everyone its been a while since i posted/been on here,anyway here"s my problem....
1. My heater control only worked on hi or the the 3rd heater option for over a year but didnt bother me so i kept it like that(unfortunately)
until it was coming on and slowly started squaling making a crazy noise then i would shut it off on and did it for a while then suddenly it like burned out and had a smell and does not work at all..??????
Btw its like 20degrees out now usually so my truck is a ice box lol

2.my truck is hard to start in the cold like when its those 20 degree days...can start on the 1st,2nd,3rd 4th,or 5th turn..but heres 1 thing i noticed happened to me about 3 times when gas is too low truck wont start..until you add gas (ex.2 gallons) and it take around 10 on and off key turns to pickup gas...now i never let it get below 1/4 tank
fuel pump?

Fuel pump?
..btw i have new spark plug wires,sparkplugs,had ignition cap and rotor ,air filter,fuel filter done in march of this year (3/12)...

Thanks for all input

Sounds like the fuel pump is failing along with your blower control resistor pack(if not the blower motor)

escaladeboss
12-27-12, 05:12 PM
Hey thanks man ,you always give good info,i will check tomorrow

the cadillac man
12-27-12, 06:10 PM
Hey thanks man ,you always give good info,i will check tomorrow

Glad to help if you need more help or have another question just post