: Rear Suspension issues



Kappa Sig
12-27-12, 02:38 PM
I've done some reading, and now trying to troubleshoot my 04 Escalade AWD 6.0.

Was getting SSD (stability system disabled) warning initially, but compressor still pumped up and seemed to work ok. Then I noticed the compressor wasn't coming on anymore, and I got the dreaded SRC message. I also noticed the last couple weeks that the compressor did work, that is was getting louder.

I have tried jumping the wire at the relay next to the fuse box underhood, and the compressor did NOT kick on.

What else should I trouble shoot before just assuming it is a bad compressor.

I also need to figure out what caused the initial SSD message. Will a good Snap On scanner ($8000 one) pull the codes out of the suspension system?

Thanks in advance!

LittleNo
12-28-12, 01:56 PM
I also need to figure out what caused the initial SSD message. Will a good Snap On scanner ($8000 one) pull the codes out of the suspension system?
I don't know about the Snapon Scanner, but if you ask this question because you want to buy one, you can get a Tech2 for much less which will be able to do ALL Diagnostic stuff for your Escalade: http://www.ebay.com/itm/GM-TECH-2-HEWLETT-PACKARD-factory-diagnostic-scan-tool-kit-/170963114309?pt=Motors_Automotive_Tools&hash=item27ce321945&vxp=mtr

And you're on the right way: get the DTCs from the Suspension Module. Everything else is guesswork. Oh and with a Tech2 you can command the compressor by hand thru the control module. Very nice feature.

But the compressor assembly is very pricy, so I anyway would test it by myself before replacing it. Remove it from the car and give 12V to the motor itself, then you know it for sure.

Kappa Sig
12-28-12, 06:28 PM
Nah don't wanna buy one LOL....have a friend that is a professional mechanic that has a really nice Snap On one. Gonna take it to him and pull codes hopefully tomorrow.

I do have an update though....the Stud 1 fuse was blown...the IGN3 was good. Getting a replacement Stud1 now and going to try jumping the compressor off again just to see.

Will report back.

the cadillac man
12-28-12, 07:28 PM
Nah don't wanna buy one LOL....have a friend that is a professional mechanic that has a really nice Snap On one. Gonna take it to him and pull codes hopefully tomorrow.

I do have an update though....the Stud 1 fuse was blown...the IGN3 was good. Getting a replacement Stud1 now and going to try jumping the compressor off again just to see.

Will report back.

I know what you mean those tech-2 units are convent but very pricey

Kappa Sig
01-02-13, 06:40 PM
Got a little bit of an update. Got 2 codes. C0455 and C0660. Replaced Stud1 fuse....no compressor action. Will hopefully have more time to dig into it tomorrow.

the cadillac man
01-02-13, 07:27 PM
Got a little bit of an update. Got 2 codes. C0455 and C0660. Replaced Stud1 fuse....no compressor action. Will hopefully have more time to dig into it tomorrow.

C0455 is Front Steering Position Sensor Circuit
C0660 is Level Control Exhaust Valve Circuit

Kappa Sig
01-02-13, 08:36 PM
So the famous exhaust valve issue with the compressor huh? Hopefully reattach the wire, or buy a compressor?

How about the C0455? Got some insight on fixing that issue? Would that be the cause of the "Stability System Disabled" message I assume?

These were the only 2 codes period. Thanks!

the cadillac man
01-02-13, 11:14 PM
So the famous exhaust valve issue with the compressor huh? Hopefully reattach the wire, or buy a compressor?

How about the C0455? Got some insight on fixing that issue? Would that be the cause of the "Stability System Disabled" message I assume?

These were the only 2 codes period. Thanks!

The compressor will have to be replaced as I have seen where some folks tried to fix it only to have it mess up again(due to the same thing) I know how you feel I have to replace mine just haven't had the time to do it but I am getting the parts to replace the worn parts on my truck

the only sensor I can think of that relates to the steering is the one in the steering column you might want to talk to a service manager at your local dealer to be sure
I ain't sure how it ties into the Stabilitrac system unless it and the cvrss shares the sensor(very possible) I do know the steering column has to be took apart to replace the sensor(not a easy job)

Kappa Sig
01-03-13, 09:45 AM
What is the cvrss you referred too? New to the Cadillac world.

the cadillac man
01-03-13, 09:53 AM
What is the cvrss you referred too? New to the Cadillac world.

Content variable road sensing suspension (some call it real time damping gm calls it magna ride)

Kappa Sig
01-03-13, 11:22 AM
Gotcha. Any clue where the steering wheel position sensor is? Is this the sensor in the column you are referring too?

----------

Doing a little research on Google...and seeing that if an alignment is performed and the system is not re-learned to the new alignment could cause C0455.

Anyone know how to re-learn the system?

Thanks!

the cadillac man
01-03-13, 02:48 PM
Gotcha. Any clue where the steering wheel position sensor is? Is this the sensor in the column you are referring too?

----------

Doing a little research on Google...and seeing that if an alignment is performed and the system is not re-learned to the new alignment could cause C0455.

Anyone know how to re-learn the system?

Thanks!

Yep it is in the column as far as the relearn I didn't have to do that on my 03 when I had it aligned

buzedliteyear
12-06-13, 06:18 PM
$8k scanner, wow you got ripped off. theyre only about 3k for the newest up to date solus. what you got?