: LS7 Clutch Flywheel Slave Install/Troubleshooting Help Needed



DaveSRX
12-10-12, 01:15 PM
My installer just finished putting in a LS7 flywheel slave and clutch into my 04V. He bled all the air out of the system. He can not get the clutch to disengage. He thinks it feels like a distance issue. My understanding was that no spacer was needed since i used LS7 slave. Not sure what to do now. :-(

FuzzyLogic
12-10-12, 02:00 PM
What's the point of paying someone to do the work if they don't know how to install a clutch properly? They should have taken the requisite measurements before assembling the car again.

In any event, the only way that we can help you is if you list the exact parts that you put into the car. There are a myriad of LS7 clutches, flywheels, and slaves available.

etcts-v
12-10-12, 02:20 PM
My installer just finished putting in a LS7 flywheel slave and clutch into my 04V. He bled all the air out of the system. He can not get the clutch to disengage. He thinks it feels like a distance issue. My understanding was that no spacer was needed since i used LS7 slave. Not sure what to do now. :-(

You don't need a spacer for the OEM or O'Rielly's slave, don't have one on mine. Did he bleed it enough?

DaveSRX
12-10-12, 02:46 PM
What's the point of paying someone to do the work if they don't know how to install a clutch properly? They should have taken the requisite measurements before assembling the car again.

In any event, the only way that we can help you is if you list the exact parts that you put into the car. There are a myriad of LS7 clutches, flywheels, and slaves available.

I bought the LS7 kit from Luke at Lindsay. Part # 12571611 for flywheel, 24237634 for slave, and 24255748 for clutch.

FuzzyLogic
12-10-12, 02:51 PM
I bought the LS7 kit from Luke at Lindsay. Part # 12571611 for flywheel, 24237634 for slave, and 24255748 for clutch.

Did he check the torque specs on the pressure plate bolts? If he overtorqued them, the pressure plate won't disengage.

DaveSRX
12-10-12, 04:49 PM
Did he check the torque specs on the pressure plate bolts? If he overtorqued them, the pressure plate won't disengage.

I will check with him. What should the specs be for the pressure plate bolts?

JFensty
12-10-12, 04:57 PM
How did he bleed the clutch? If he has a mityvac its the best way to get immediate pedal. Then finish it off with the pump / bleed method. I had no problems when I installed mine and bled it this way.

JFensty
12-10-12, 04:57 PM
Dave aren't you located in PA?

FuzzyLogic
12-10-12, 05:03 PM
I will check with him. What should the specs be for the pressure plate bolts?

Flywheel torque sequence in star pattern:
Step 1: 20 Nm 15 lb-ft
Step 2: 50 Nm 37 lb-ft
Step 3: 100 Nm 74 lb-ft

I actually found that you can get away with around 50 ft-lbs of torque on the pressure plate bolts if you use blue Locktite. Doing so raises the clutch disengagement point by about a half inch. I've been running like that for 8,000 miles with no problems. FWIW, stock pressure plate torque specs (http://www.cadillacfaq.com/faq/answers/torque.html) are 52 lb-ft.

DaveSRX
12-10-12, 05:39 PM
Dave aren't you located in PA?

Yes. Harrisburg area.

JDB
12-10-12, 09:21 PM
[/COLOR]
How did he bleed the clutch? If he has a mityvac its the best way to get immediate pedal. Then finish it off with the pump / bleed method. I had no problems when I installed mine and bled it this way.

What flywheel bolts did you use?

JFensty
12-10-12, 09:24 PM
New flywheel bolts from Luke. I reused the stock pressure plate bolts with some loctite

OneFast V
12-10-12, 09:51 PM
Flywheel bolts from the dual mass flywheel are too long to properly torque the ls7 flywheel. you need new ls1 style M11x1.5" flywheel bolts.

DaveSRX
12-11-12, 09:54 AM
Couldn't i just use GM LS7 bolts?

01Cummins
12-11-12, 12:32 PM
I didnt use new bolts as I was advised that they were not needed. My LS7 works perfect. I pressure bled my slave and pedal is perfect. Pressure bleeding is the ONLY way to get all the air out..

DaveSRX
12-13-12, 08:11 AM
Guys thanks for all the input on my issue. We found out the problem was the metal clutch line coming out of the slave was kinked. We fixed/rebuilt the line and all is good now. Loving the new flywheel and my new Pisnuoff shifter. Also did Revshift trans mount insert. Car is transformed for the better!

JDB
12-13-12, 11:44 AM
:cool:

Please don't let me test drive your V :bouncy: