: Rough idle/shuddering and misfires...2004 SRX Northstar



DougC..
12-08-12, 04:05 PM
Hello,

My wifes 2004 srx awd with N* is having some problems and Im not really wanting to take it in if I can find the fix myself.
Upon startup will idle a bit rough and you can feel a little shake back and forth from idle. Under light load I can hear that its not running right, and under med to heavy load we get misfires.
problem started out as occasional misfire, that got worse and worse. Now we are nervous about driving it at all.

I changed the oil, fuel filter, spark plugs but problem is still there. We also ran a bottle of techron to see if maybe an injector might be slightly plugged. Could I have a vac leak causing a fuel pressure problem?

codes are

P2097 Post Catalyst Fuel Trim Sys Too Rich Bank1
P2099 as well
P0300 Random/Multiple Cylinder Misfire Detected
P0326- Knock Sensor1 Circ Range/Perf (bank1/1 Sensor)
P0331- Knock Sensor2 Circ Range/Perf (bank2)
P0521 Eng Oil Pres Sensor/Switch Circ Range/Perf

Thanks for any ideas.

Submariner409
12-08-12, 04:15 PM
The rich fuel trim codes - Possible FPR - Fuel Pressure Regulator. It's a small domed canister on the end of the fuel (injector) rail just before the return line to the tank - held in by a hairpin clip. There should be a vacuum line attached to the side, which runs to a nipple on the throttlebody. With the engine off, pull the vacuum line off the FPR nipple. ANY raw fuel in the line or nipple ? If so, it's new FPR time (and a bad FPR will screw up your gas mileage, too.) You pull the clip, remove the FPR, making sure the lower O-ring comes out. Oil the new unit O-rings and press it in in exactly the same orientation as the original or you won't be able to snap the clip back into place.

The oil pressure circuit may just be a dirty connector - left lower side of the engine at the oil filter adapter ???

Pictures and diagrams of the 2002 Northstar fuel rail and related items in my albums. Click my username and open the profile. 2 albums, 6 pages in there.

Talk to Chris in parts at Rippy Cadillac over there >>>>

DougC..
12-08-12, 04:25 PM
Submariner, thanks for the help. I'm headed out to see if this can fix the problem. I will report back.

stoveguyy
12-18-12, 02:30 PM
its been a week now. where did he go? a misfire is usually ignition. i assume the srx has a coil pack/module? of course if you post this question in the srx forum you will get zero responses. people with srx vehicles do not work on them. they pay people to work on them.