: No sound



ETC93
12-01-12, 09:14 PM
Dear All,
I just got a Baby Luxury Sedan and found out there is no sound coming out from the radio. Would you have any suggestion ?
Nice car by the way !

S70RMP
12-02-12, 09:02 AM
has the radio been taken out and checked that the speakers are connected. previous owner may have had a different head unit in.

ETC93
12-02-12, 03:03 PM
Fuses are all ok, lighter does not work either, I don't know if the radio has been taken out, the car has a low mileage, maybe I have to take it out and check. The radio turns on, does not ask for a code but just no sound... There is no phone, maybe there was one before and while removing it some connectors were removed ? Any idea about how to remove that radio in a smouth way ??

S70RMP
12-03-12, 05:06 PM
you'll need a removal tool just locate a Saab one

ETC93
12-03-12, 09:22 PM
Yes... a few threads below this one, I found and went through the body repair manual, lets of very interesting and helpful information in there !!

S70RMP
12-04-12, 03:41 AM
we need to see a picture of your BLS :-)

what model / spec is it ?

ETC93
12-04-12, 07:49 AM
It's just a daily car, easy for us as we have 2 children. it has a 1.9Tid engine (110KW) and 6 speed auto gear, it has a leather upholstery and Xenon headlights, no navigation system. I don't know the exact version.
It could be Bussiness, Elegance or Luxury, probably not Luxury ? I will post some pictures maybe you know what it is exactly ?

Mazuk
12-04-12, 11:29 AM
You may already have seen this If not there might be a remote possibility it may help.



http://www.ifseurope.eu/manual/BLS%20manuals/Infotainment.pdf

ETC93
12-04-12, 08:15 PM
Thanks Mazuk, I went through it yesterday morning and found out the radio can't be used in another car without going to a dealer (page 3) although I believe mine has never been taken out before but batterie has probably been changed. I got it out yesterday morning and checked all the connections.
Everything seems OK to work fine but the most important (the sound) is missing... :banghead:
Speakers are connected, there is no error code...

ETC93
12-19-12, 07:37 PM
So, here a little update :
This car has a non Bose audio system with 7 speakers and one amplifier in the trunk ref : 4617163
I opened the amplifier and found inside an electronic component out of order (Toshiba TA8225H), don't know yet if there is more damage but at least I start to find out why there is no sound...
Maybe I will buy another one or get this one repaired and then see if it comes back to life...

S70RMP
12-19-12, 08:42 PM
I personally would replace it with a new unit, I have the Kenwood DNX7210BT in the 9-3 which if I had still got the BLS I'd have loved to put in there.

ETC93
12-20-12, 09:38 AM
I just bought a tested unit from ebay/uk, will see in a couple days...

ExRPO1
12-21-12, 04:38 PM
I personally would replace it with a new unit, I have the Kenwood DNX7210BT in the 9-3 which if I had still got the BLS I'd have loved to put in there.

Did you put this in (or have it professionally installed)? how much etc. Looks good on the reviews and what's more, at least (I'm assuming) updating the Garmin powered satnav is a darn sight easier than the present outdated and extremely expensive satnav discs. I now use tomtom HD live. So much better than the BLS onboard satnav, which is now so out of date, it is almost worse than useless! Not being able to put postcodes into the BLS fitted standard unit is an absolute pain in any case.

How does your DNX7210BT get on with your mobile phone/steering wheel controls etc? This is the only thing which is really stopping me from investigating a replacement for my existing unit, because I wouldn't want to lose connectivity functionality with my iphone. One final issue, there doesn't appear to be DAB radio available on this unit and there is still a move by the Government to move us all onto DAB in the future. Wouldn't want to spend a shed load of money only to have to upgrade further later on because the best radio stations will have moved to DAB only.

S70RMP
12-22-12, 03:34 AM
I had it installed at by a proper installer. everything is updatable via usb, I'be updated the firmware 3 times since having it from here http://www.kenwood-electronics.co.uk/support/updates/navi/dnx7210bt/

it deadeasy to do. not had aproblem with my iPhone 4s and the DNX7210BT I've even had it streaming internet radio while crusing down the motorway.

I had been hanging on and on waiting for them to release a unit with DAB as I justed to have it, I still have the Kenwood DAB receiver sat in the garage but it will not connect to new Krnwood units.
I also had them install the steering wheel pluggin and that works perfectly.

I have always had TT's up to this unit and I like TT's but I've got used to the garmin very very quickly.

I'm guessing that at some point Kenwood will bring out a DAB pluggin and a software update to allow it to run.

ETC93
12-22-12, 05:51 AM
Good to know ! I've an original radio 7 speakers without navigation, I bought only another amplifier so if there is still no sound it might be a good idea to replace the head unit.

S70RMP
12-22-12, 06:05 AM
I'm so glad I did, i've got my 160gb ipod connect at all times now as well so endless music

ExRPO1
12-22-12, 07:36 AM
I had it installed at by a proper installer. everything is updatable via usb, I'be updated the firmware 3 times since having it from here http://www.kenwood-electronics.co.uk/support/updates/navi/dnx7210bt/

it deadeasy to do. not had aproblem with my iPhone 4s and the DNX7210BT I've even had it streaming internet radio while crusing down the motorway.

I had been hanging on and on waiting for them to release a unit with DAB as I justed to have it, I still have the Kenwood DAB receiver sat in the garage but it will not connect to new Krnwood units.
I also had them install the steering wheel pluggin and that works perfectly.

I have always had TT's up to this unit and I like TT's but I've got used to the garmin very very quickly.

I'm guessing that at some point Kenwood will bring out a DAB pluggin and a software update to allow it to run.

Thanks for getting back with the info. Concerning my iphone, it is a 3G model, fully up to date with the latest ios 6.1, but I'm not sure looking at the Kenwood site, whether it will work ok with the particular unit you have. That would be a shame if it doesn't, because I bought my handset outright (460 brand new) and I have no intentions of upgrading a perfectly good iphone for a newer one, especially when it works brilliantly with the existing unit in the BLS.

I think I could be waiting just a little longer. I'm guessing Kenwood will release a DAB unit sometime in the not so distant future and as I have plans on keeping the BLS for many years, it would probably be worth the wait. That being said, I suppose the far cheaper option would be to keep the existing head unit, by a PURE Highway 300Di http://www.halfords.com/webapp/wcs/stores/servlet/product_storeId_10001_catalogId_10151_categoryId_2 65865_productId_910735_langId_-1?cm_mmc=Shopping-_-Google%20Product%20Search-_-In-Car%20Technology%2FDab%20Radios%2FDAB%20Car%20Radi os-_-PURE%20Highway%20300Di%20In-Car%20Digital%20Radio%20Adaptor&source=shopping and continue to use my tomtom 820 live. Oh, choices, choices!!

S70RMP
12-22-12, 05:22 PM
my friends on 3G iPhone works perfectly with the 7210, I was hanging out for ages awaiting a DAB option but to be honest I've listened to the radio maybe 3 times since it was installed, it's either music via the ipod or SD card or even streaming via bluetooth.

ETC93
12-23-12, 11:59 AM
Head unit replacement sounds interesting, are these items anti theft code protected ?
I would not like to end up with such a radio gone and then driving home with a broken door or window... :annoyed:

S70RMP
12-23-12, 05:35 PM
The screen comes off :-)

ETC93
01-10-13, 07:21 AM
I received the amplifier today and miracle : it works !:thumbsup:
So if no sound, check for stinking amplifier, eventually open it and have a look

S70RMP
01-10-13, 08:38 AM
good news for you

I had to nip around tot he vets the other day and parked further down the road was a red BLS, God I miss my BLS :-(

ETC93
08-14-13, 08:22 PM
Just in case, I got my original amplifier repaired by a friend who is specialized in electronics (the kind of guy who reads electronics like we do with the news paper...) as I bought another one I have a spare unit now. If needed, he might be willing to repair yours too, if you need any help or assistance, I don't mind to ask him.