: VIN info



wyched7006
11-23-12, 10:15 AM
I plan on buying a 2011 STS ...not sure about options any way to tell which pkg. by vin number?

Submariner409
11-23-12, 10:32 AM
Enter the VIN, case specific, into the box in www.compnine.com

It's a subscription site, so you get only one entry per day. Study the page and set up your special options that make your car specific, then save the page to a file on your hard drive. Print.

chazglenn3
11-23-12, 05:10 PM
Or you can open the trunk and look at the label on the underside of the spare tire cover.

Subsailor613
11-23-12, 08:59 PM
The Packages are listed as: 1SA or 1SB, 1SF, or 1SG, The 1SA being having the Least of the options, and 1SF, and 1SG
have the most options, however, you could have a 1SF with option 6 or 7, which gives you some additional.
If you like options,Either way members listed above, take a picture of the label in the trunk,and use it to evaluate, what options
that particular vehicle has,using Comp Nine, and print a copy for yourself,as it will only let you in once a day.
Some of the MOST desirable options are: ACC=Adaptive Cruise Control K59 with HUD=Heads Up Display UV6,
Lane Departure Warning UFL, Side Blind Alert UFT, combined sometimes called Driver Awarness package Y53
Brembo Brakes J56, I think ONLY come on the -V series. The better brakes are the JE5.
The Nav is highly recommended, as other options come with the Nav.XM radio,CD changer etc.
F55 is the Magnetic Ride control, G80 is Positraction , wheel sizes,sunroof, and spoiler are obvious.
KB6 are the Cooled seats,Most have the heated seats.
This should give you enough info to intelligently choose.
If you need specific help, come back here, a lot of members here, have the 1SG option .
Happy Hunting ! :cool2::cool::cool2:

Mullah88
11-25-12, 10:58 AM
i think you missed one, cause mine says "1SC PACKAGE-OPTION 03 (1SC) SALES PACKAGE SALES PKG(1SC)" "1SZ PACKAGE OPTION- (1SZ)"

Ludacrisvp
11-25-12, 11:04 AM
The 1SZ is nothing more than a sales discount package... It might even be the spoiler delete credit for the AWD models.

curtc
11-25-12, 11:55 AM
The 1SZ is nothing more than a sales discount package... It might even be the spoiler delete credit for the AWD models.

Mine has 1SZ listed, but it's a RWD 1SF car w/ the spoiler so that's not it :)

Mullah88
11-25-12, 12:25 PM
mine is also a RWD w/ spoiler...meh, contemplating trading it for an 07 v8 (i prefer the front grille of the 05-07 better)

---------

guess my rain sense wipers dont function..correctly? i know on my 98 seville all i had to do was leave the wiper on and it sensed how heavy the rain poured and adjusted the speed of the wipers accordingly...my sts does not do that hmm

lol loving this site, so i have the JE5 brakes (lots of brake dust tho)

EChas3
11-25-12, 07:20 PM
I have a spoiler on my AWD 1SG!

ddalder
11-25-12, 07:34 PM
At least for the 2006 model year...

1SZ - PREFERRED EQUIPMENT SAVINGS

Ludacrisvp had it nailed.

EChas3
11-25-12, 08:32 PM
guess my rain sense wipers dont function..correctly? i know on my 98 seville all i had to do was leave the wiper on and it sensed how heavy the rain poured and adjusted the speed of the wipers accordingly...my sts does not do that hmm


The Rainsense module is mounted directly to the windshield. If the windsheild is dirty, the system doesn't work well. On the control stalk, there's a ring to control the sensitivity of the Rainsense system as well. If the system malfunctions, this ring functions as as a more conventional intermittant wiper.

GM canceled all Rainsense in 2010. Idiots!

Mullah88
11-25-12, 08:46 PM
yeah mine works like a conventional wiper (does not sense anything lol) and my windshield is pretty clean. i thought the module was mounted on the rear view mirror assembly? if its directly on the windshield then i have an idea why it doesnt work. the car when i bought it didnt have the OEM windshield

chazglenn3
11-25-12, 10:18 PM
It's a square black box glued to the windshield to the right of the rear view mirror as you are sitting in the drivers seat. The box attached to the mirror is for the Intellibeam high beam sensor.

ddalder
11-26-12, 12:42 AM
Look at the Service Parts Identification label on the underside of your spare tire cover. First of all, make sure the VIN number matches (some people have found the spare tire cover is not the one that came with their car, therefore the option label was incorrect). If you have code CE1 your car is supposed to have RainSense wipers. No CE1 code, no RainSense.

It's possible that without the OEM windshield, the replacement may not be correct. If your car is supposed to have CE1, it was likely disconnected with the wiring tucked into the headliner. The mount is attached to the windshield (including replacement glass). If the prior owner didn't know/specify that it had RainSense, the wrong windshield was installed.

Ludacrisvp
11-26-12, 01:32 AM
Yeah you need to specify that you have it, when I replaced the windshield on the 02 Deville I had to specify the rainsense option. It comes with the sensor attached to the new windshield (you cannot swap the sensor from one windshield to another). It worked just as well on OEM and replacement windshield.

ddalder
11-26-12, 01:38 AM
There are ways to transfer the mount from another windshield, but it isn't straight forward and there is a part required which most shops would need to order. I had to go through this to add this option to my Bonneville. Since it was never available in this car, I couldn't simply order a different windshield.

Ludacrisvp
11-26-12, 02:13 AM
You add all sorts of crazy things to cars that likely makes GM's stomach turn when you do the thing they said couldn't be done.

ddalder
11-26-12, 02:22 AM
You add all sorts of crazy things to cars that likely makes GM's stomach turn when you do the thing they said couldn't be done.
GM has no business telling people what options they can or can't have :D

Mullah88
11-26-12, 08:33 AM
definitely have it

http://i135.photobucket.com/albums/q137/chimam2002/2012-11-26082443.jpg?t=1353936434

http://i135.photobucket.com/albums/q137/chimam2002/2012-11-26082529.jpg

Ludacrisvp
11-26-12, 08:44 AM
definitely have it

http://i135.photobucket.com/albums/q137/chimam2002/2012-11-26082443.jpg?t=1353936434

Yup, my wiper stalk looks the same as yours, and I see the CE1 code.

Check for the sensor on the windshield / wires that are not attached, some people unplug the sensor because they don't like the rainsense features.

Mullah88
11-26-12, 09:41 AM
due for maintenance anyways, ill take it to a cadillac dealer over here and hear them out

ddalder
11-26-12, 07:52 PM
The wiper control is the same in all STS's for 2005-11, whether the car has RainSense or not. The RPO codes are the giveaway. My question would be whether you see the module attached to the windshield or not.

The control acts in one of two ways. The RainSense module is connected to the wiper control module. There are two (pulse width modulated) data lines linking the two. If communication is interrupted for any reason, the wiper control module defaults to "Delay" wipers instead of RainSense. If RainSense is working, the control adjusts the sensitivity of the module to moisture on the windshield. If RainSense is either not working, or not present, the same control adjust the delay interval used by the wiper contol module.

Mullah88
11-26-12, 08:27 PM
i think i got the module your talking about...and it seems to be connected (i checked it and seemed fine)

http://i135.photobucket.com/albums/q137/chimam2002/2012-11-26201542.jpg
didnt pop open the enclosed part but every thing looks fine to me

http://i135.photobucket.com/albums/q137/chimam2002/2012-11-26201727.jpg

http://i135.photobucket.com/albums/q137/chimam2002/2012-11-26201752.jpg

also did the adjustment of the wiping intervals but it does not work...

for example my 98 stays on all the time (i leave it on...except for when i go through a car wash) and when it sensing rain, it wipes and if the rain is pouring, it wipes faster. the 06 is the same speed throughout and if i leave the wiper on, it wipes whether it senses rain or not

ddalder
11-26-12, 08:35 PM
Yes, the module seen in the first picture is the one. There is a small tab on the side of the connector. You can always try pressing the tab and disconnecting the connector. Reattach the connector and make sure it is seated firmly. While they are apart, check for what looks like any bent pins on the male side. If the windshield replacement technician was careless, this may be part/all of the problem.

----------

Once reconnected, turn the wiper control to one of the middle positions, but not as far as low. Take a small glass of water and slowly pour it over the glass where that sensor module is located and see if it activates the wipers.

Mullah88
11-26-12, 08:36 PM
gotcha! will do that tomorrow and see what happens

ddalder
11-26-12, 08:39 PM
Sorry, should have said make sure the control is set to the Delay/RainSense setting and adjust the delay/sensitivity control to somewhere in the middle.

Mullah88
11-27-12, 05:30 PM
so happens to be raining over here (Charlotte). i unplugged the module and all the pins are fine, plugged it back in and nothing. its not that big of a deal, its one of those convenient features

ddalder
11-27-12, 10:24 PM
Depending on how much you want this, your skill level and whether you have a multimeter, there are other things you can check.

----------

If you want to pursue this though, perhaps start a new thread. This one has wandered seriously off topic ;)