: Radio problem, touchscreen Nav



ccruzan
11-11-12, 09:46 PM
My 2005 Escalade has a new issue. I tried to search for an answer no luck. Tonight I got in the beast to drive home and it barely started. I ran by a local service center to get the battery checked and they said it would have to be charged before they could check it. I didnt have time to wait so was going to head home to charge it first and go by tomorrow. When I hopped back in the radio was off. I hit the power button and all the lights came on but the screen stayed black other than the clock coming on like when the radio is off. The nav dvd was spinning. All this lasted about 10 to 15 secs then everything went back off. This same thing happens every time I try to turn it on since. No sound ever starts just so you know.
Any ideas?

the cadillac man
11-11-12, 10:17 PM
My 2005 Escalade has a new issue. I tried to search for an answer no luck. Tonight I got in the beast to drive home and it barely started. I ran by a local service center to get the battery checked and they said it would have to be charged before they could check it. I didnt have time to wait so was going to head home to charge it first and go by tomorrow. When I hopped back in the radio was off. I hit the power button and all the lights came on but the screen stayed black other than the clock coming on like when the radio is off. The nav dvd was spinning. All this lasted about 10 to 15 secs then everything went back off. This same thing happens every time I try to turn it on since. No sound ever starts just so you know.
Any ideas?

Check the battery cables I had this happen to me thanks to the guy at auto zone not making sure the cables were tight I checked the cables and tightened them then pulled the fuses for the radio, amp and onstar system in order to get it back to working