: Cooling leak



gvjv3
11-07-12, 12:24 PM
Hello

I have a 97 Catera, the other day I went to check my coolant, I started to open the reserve tank then forgot it was still hot and it started to come out so I closed it before any coolant got out, now I have a leak some were, stream rises from the pass. side rear bottom of the motor, car does not get hot but i lose coolant, also if I turn on the heat the leak stops,
any ideas what I should be looking for?

investor74
11-07-12, 04:13 PM
Nothing you did can cause a leak. It may be that some coolant remains in the overflow tube and drops down on the hot engine causing steam. Double check that you are still losing coolant.

If you are still losing coolant, the location you describe sounds like the heater control valve.

BTW, you are lucky you didn't hurt yourself. ;)

gvjv3
11-07-12, 11:24 PM
ok, just strange when I turn on the heater no leak and when I turn of the heater steam comes out, yes I lose coolant, lots when I have the heater off, very little to none when i have the heater on, would anyone know where this heater control value is location is? and what it looks like?

Thank You

investor74
11-08-12, 07:02 AM
The heater control valve is back toward the firewall on the passenger side. It has three hoses and a vacuum line coming out of it. The easiest way to find it is to locate a heater hose and follow the hose to the valve. These valves are a problem area in the Catera and would be my first choice for finding a leak in the area you describe.

kaustein
11-08-12, 10:00 AM
Nothing you did can cause a leak. It may be that some coolant remains in the overflow tube and drops down on the hot engine causing steam. Double check that you are still losing coolant.

If you are still losing coolant, the location you describe sounds like the heater control valve.

BTW, you are lucky you didn't hurt yourself. ;)

Heater control valve is a common problem!

elvin315
11-08-12, 05:27 PM
A HBV replacement article with pictures from the Omega Owners Forum:

http://www.omegaowners.com/forum/index.php?topic=90574.0

Be sure to thank them.

gvjv3
11-09-12, 01:53 AM
OK I found the value, its cover in coolant, so am sure it's leaking, now the only thing is how to replace it? I had to bend my arm 3 different ways just to reach down and back behind the motor just to grab it with my hand and feel it was all wet with coolant, there's no way i can get any tool in my hand back there, so do i take the manifold off? or is there a special way?

Thank You

----------

oh by the way this site is banded for use.

http://www.omegaowners.com/forum/ind...?topic=90574.0

jupiter57
11-09-12, 05:36 AM
OK I found the value, its cover in coolant, so am sure it's leaking, now the only thing is how to replace it? I had to bend my arm 3 different ways just to reach down and back behind the motor just to grab it with my hand and feel it was all wet with coolant, there's no way i can get any tool in my hand back there, so do i take the manifold off? or is there a special way?

Thank You

----------

oh by the way this site is banded for use.

http://www.omegaowners.com/forum/ind...?topic=90574.0

Better link:
http://www.omegaowners.com/forum/index.php?topic=90574.0

gvjv3
11-09-12, 12:16 PM
bad site, will not me in, thanks for trying.