: Windshield Fluid Nozzle Cleaning?



Smark
11-07-12, 11:44 AM
Hello everyone,

I own a 2001 Catera Sport that's in pretty decent shape. About 5 months or so ago the washer nozzles stopped working properly. before then the washers got used roughly weekly and worked perfectly, to the point I've refilled it with a full bottle of fluid over the course of a year. Now the jets steam a sad spray and just kind of spurt/seep out, not high pressure jets like I'm used to. They squirt barely onto the bottom of the windshield and usually only one side at a time.

I figured this was primarily indicative of the fluid pump going, so I pulled out the pump and broke a brittle piece if the nipple in the process. the motor was working fine, i bought a new motor and put that in. I then traces the fluid line to above the battery and unhooked it at that joint there, full pressure, so its not a blockage at the first half of the line. I took apart the wiper housing and noticed that there were wired hooked to the nozzles... I figure these are for heat or something. I put everything back together and ran some solid wire about a half inch into all four nozzles, two on each side of the windshield.

The nozzles seemed to work better right after I cleaned them out, but wouldn't work the next day. I think I'm on the right track, just don't know how to clean them.

Any suggestions for cleaning these the proper way? I would say remove them and soak them in CLR or something, but they're attached by more than just the fluid hose. I tried searching the forums here but didn't see any good threads. Maybe I missed them.

Thank you for your time,
Smark

investor74
11-07-12, 09:21 PM
One thing to check is that the hose isn't cracked or pinched where it transitions from the engine compartment to the hood of the car (I assume the setup in the 2001 is the same, with the nozzles on the hood). I had a cracked hose.

Smark
11-08-12, 06:13 PM
One thing to check is that the hose isn't cracked or pinched where it transitions from the engine compartment to the hood of the car (I assume the setup in the 2001 is the same, with the nozzles on the hood). I had a cracked hose.

I opened up the whole compartment under the hood where the wiper tie-bar is. Theres nothing pinched that I can see. Also, the sprayers are NOT attached to the hood, they're attached to the top of the firewall and sit under the hood overhang.

Thanks you for your time,
Smark