: 05 escalade revs before shifting!!



Hammer05
11-03-12, 04:24 PM
Hello, I have a 2005 escalade esv that is doing a little extra rev before it shifts. I don't think that it's a tranny problem but what do I know!! It feels more like a sensor or computer related issue. Does anybody have advice on this? Id rather try to fix it myself before I bring it to the dealer and get a big old bill. I cleaned the throttle body and the MAF sensor and it is still happening. Thanks in advance :)

the cadillac man
11-03-12, 06:36 PM
Hello, I have a 2005 escalade esv that is doing a little extra rev before it shifts. I don't think that it's a tranny problem but what do I know!! It feels more like a sensor or computer related issue. Does anybody have advice on this? Id rather try to fix it myself before I bring it to the dealer and get a big old bill. I cleaned the throttle body and the MAF sensor and it is still happening. Thanks in advance :)

Sounds like you need to check the fluid level as it sounds like it is low

Also is the check engine light on? If yes then it may be something else if no then check the fluid level

sprink60
11-03-12, 07:42 PM
Yes...check the fluid level because that is and indication of loss of line pressure or worn clutches. When was the last transmission fluid change?

Hammer05
11-04-12, 12:53 AM
Tranny was serviced 2000 km ago. Fluid is at the proper level.

the cadillac man
11-04-12, 01:07 AM
Tranny was serviced 2000 km ago. Fluid is at the proper level.

Was the filter changed and is the check engine light on?

sprink60
11-04-12, 01:12 AM
I think you need to have a trusted independent transmission specialist in your area drive your truck, give you an expert opinion as to what you are facing and go from there.

the cadillac man
11-04-12, 01:25 AM
I think you need to have a trusted independent transmission specialist in your area drive your truck, give you an expert opinion as to what you are facing and go from there.

+1 I agree get a pro that knows what he is doing(if you see another building next to the tranny shop and the workers are going to and from each RUN trust me I know(I had it happen with my car not fun or cheap)

xstein61
11-05-12, 11:52 PM
I had the same problem on my 06. Luckily it was under warranty from a previous transmission problem (don't get me started). It was obvious to me, because I drive it every day, but the shop called it a "slight flare" on shifting. It seemed to be worse on the 1-2, 2-3 shift, and they didn't want to do anything. It turned out to be a valve in the tranny (eps/Power valve) that after replacement made it feel like a whole new truck. Don't wait to get it checked out, because the shop said if I hadn't brought it in the tranny would have been fried. I can look through the paperwork to get the exact part, but the shop owner detected it as soon as he drove it.

sprink60
11-06-12, 11:44 PM
I had just a bit of slip that I felt was very slightly unusual. I flushed mine and refilled with Dexron VI Synthetic. I then used my programmer to bump the line pressure of all three shifts to 16 PSI over stock. Now it is crisp and firm.

You may also want to consider a bottle of Lucas Trans Fix. I have used it in some of my GM and Ford work trucks with amazing results.

Jason Bussart
01-16-13, 04:03 PM
I am having a similar problem with my 03 Escalade but its only in the morning when the truck is cold?? Any ideas?

the cadillac man
01-16-13, 04:50 PM
I am having a similar problem with my 03 Escalade but its only in the morning when the truck is cold?? Any ideas?

Check the fluid level
First work the tranny up to normal temps before you do this
Second start at 1 and shift gear by gear back to park and check the fluid level if its low then you will need to add some
I had this happen with my 03 and I added some fluid and the tranny shifts right and smooth now