: Headlights dim when automatically come on, but not when manually engaged 2001 ETC



Dollar Bill
10-22-12, 07:40 AM
2001 Eldorado ETC

When I start the engine and put the transmission in Drive, the two inner headlights automatically come on, but they are very dim. When I pull back on the turn indicator stalk, the high beams come on, but won't stay on unless I keep the stalk pulled back.

However if I pull out the headlight switch, everything works fine. High beams stay one and everything is bright.

Having read the manual, it seems that this situation is caused by the Daytime Running Lamps (DRL), I do have the Twilight Sensor engaged, but something must be off in the sensor that tells the car it is dark, because this does not change when it IS dark!

Where can I find this sensor?

Thanks in advance,

Bill

rodnok01
10-22-12, 11:12 AM
Sensor is on dash, usually in the center. Might try cleaning it. I have had them act up when dirty.

Submariner409
10-22-12, 02:33 PM
IF - and this is a big IF because Eldorado was not updated for 2000+ - the ambient light sensor is a small flat disc 1/4" recessed into the driver's end (left) of the defroster grille in the dash top. The two ?? dark "bubbles" in the dash top are HVAC heat load sensors.

Daylight: DRL on (DRL are inner beams: high beams set to series, low light level), high beams flash-to-pass only. Low beams manually turned on, DRL drop off. Same flash-to pass, push the stick forward, high beams.

Night time, no sentinel, you should get a "Headlamps recommended" message. Lights on low beam, flash-to-pass, high beams - push stick forward.

Sentinel: Lights come on low beam automatic, other functions same. (No DRL)

Dollar Bill
10-25-12, 06:48 AM
Submariner 409 - I have one "bubble" in the forward middle of the dash (easily removable plate) and a recessed blue disk that I suppose is the ambient light sensor. If this sensor fails, does the car think it is daylight? Is there a safe way to test it? Short the terminals?

I tried turning off the Twilight Sentinel, no "Headlamps recommended" msg. Even tried covering the recessed disk (blue) with a magazine, even though it was dark outside. No message. Should I try replacing the recessed blue disk, or "upgrade"? (Not sure what this would entail)

For what is is worth, here are my codes:

IPC B1552 History Keep Alive Memory (KAM) Error
IPC U1040 History Loss of Class 2 Communications with ABS
IPC U1255 History Loss of serial communications for class 2 devices
IRC B1327 History In Car Air Temperature Sensor
IRC U1301 History Class 2 Short to Battery
PCM P0171 Current Fuel Trim System Lean Bank 1
PCM P0174 Current Fuel Trim System Lean Bank 2
PCM U1040 Current Loss of Class 2 Communications with ABS
PCM P0300 History Engine Misfire Detected
PCM P1381 History Misfire Detected - No Communication with Brake Control Module
PCM P1571 History Traction Control Torque Request Circuit
PCM P1644 History Traction Control Delivered Torque Output Circuit
PZM B1552 History Keep Alive Memory (KAM) Error
PZM B1558 History BCM EPROM Checksum Error
PZM B1971 History Inadvertent Power
PZM B1982 History Device Power Circuit High
PZM B1983 History Device Power Circuit Low
PZM B2471 History Interior Lamp Fault
PZM B2473 History High Beam Fault
PZM B2477 History Reverse Lamp Relay Shorted to Ground
PZM B2550 History Storage Mode Entered (Backup Lamps Control Circuit)
RFA B1327 History In Car Air Temperature Sensor
RFA U1064 History Loss of Communications with DIM
RSS C0635 Current Left Front Normal Force Circuit Malfunction
RSS C0640 Current Right Front Normal Force Circuit Malfunction
RSS C0710 History Steering Position Signal Malfunction
SDM U1040 Current Loss of Class 2 Communications with ABS
SDM U1255 History Loss of serial communications for class 2 Class 2 Short to BatterY

rodnok01
10-25-12, 08:47 PM
The BCM controls twilight if memory serves me correct.
That's alot of codes, have you had elec problems?

Dollar Bill
10-26-12, 05:25 AM
The BCM controls twilight if memory serves me correct.
That's alot of codes, have you had elec problems?

Yes. Battery drain. If left for more than two days w/o starting. Battery dead. Was getting other codes indicating ECBM was problematic, but those codes quit showing up.

It was suggested that my problem here would be either the Twilight Sentinel switch or the SunLoad sensor.