: 2000 Escalade Battery Problems!



Tommy77maroon
10-21-12, 11:00 AM
Hi, I am having a problem with my truck having enough juice to start after sitting for a while. I replaced the BCM a month ago and from what I can tell nothing is staying on in the car when its off. It takes about 6 hours for it to drain the battery enough to were it wont start. I have no idea what could be wrong? Anyone had a problem like this? HELP PLEASE

the cadillac man
10-21-12, 04:27 PM
Hi, I am having a problem with my truck having enough juice to start after sitting for a while. I replaced the BCM a month ago and from what I can tell nothing is staying on in the car when its off. It takes about 6 hours for it to drain the battery enough to were it wont start. I have no idea what could be wrong? Anyone had a problem like this? HELP PLEASE

Sounds like a module has a internal short find out what isn't working (I know how you feel I had the rear air module fail and it did the same thing)

Tommy77maroon
10-21-12, 05:41 PM
Sounds like a module has a internal short find out what isn't working (I know how you feel I had the rear air module fail and it did the same thing) Ya I just seen that rear air module problem on a other site, So I just pulled the fuse for that now so now will have to wait and see if it starts later tonight

the cadillac man
10-21-12, 08:59 PM
Ya I just seen that rear air module problem on a other site, So I just pulled the fuse for that now so now will have to wait and see if it starts later tonight

If it is the problem i did a how to with pics on how to get to the system(it's in the how-to FAQ section)