: 2007 Esc- install of 2011 Tahoe VCIM #22794713 - help with onstar activation Tech 2



David999
10-12-12, 12:06 PM
I have a 2007 escalade with no bluetooth. Purchased a #22794713 VCIM with bluetooth antennae for $220. Install was a snap. Panels pop off easy (tip-raise the cup holder cover, and then grab edge and pull the whole panel up gently), center panel comes easy as well along with panel above glove compartment. You will need to unplug the connection to the three bottons on the driver side of center panel - I then simply flipped panel to rest on passenger seat. Unscrew the bolts holding the entertainment unit in place, and remove - you do not need to remove HVAc or lower component. Unplug electrical connections from back and put the entertainment console aside. VCIM is visible with two plastic connectors on either side. Lift out. I noticed that the new VCIM is missing the GPS antennae connector. I gather that new vehicles have both GPA and cell reception in a single cable; so problem #1 - no gps connection to vcim. I left that loose. Reconnected everything and bluetooth works perfectly. Onstar has red light though, when I press emergency button, I get connected, but as soon as they hear "red light' they suggest a visit to dealer.

So, I have new unit installed and blue tooth works perfectly with iPhone, but I want onstar essentially for the remote iPhone app.....

I went to dealer to flash the VCIM with my VIN etc. They were happy to try. I read online that it involves a Tech 2 connection and running "VCIM/OnStar Setup procedure" which I asked them to do.

However, they followed the bulletin for "Onstar Reconfiguration which involves TIS 2 Web Gen 4). They told me that when they entered the make and year in SPS (Sytem Programming SYstem), it would not recognize VCIM as Gen 6 was not standard on 2007 and not supported..... so end of road.

Question. Should dealer have run TIS and OnStar Activation programming event using SPS, or should we get them to just connect Tech II and run update.....

What is best way to get rid of that red light and have it flashed so onstar can migrate account to new vcim. OnStar seems happy to migrate account, but the red light concerns them..

Last Q - is the red light because the GPS antennae not connected. Do we need to but a new antennae fin with both GPS/Cell in single cable and plug that in?

djredman99
03-06-13, 04:43 PM
Great question as I am looking into this issue right now. I know there are lots of threads on this but I am looking for the solution where there are no issues with the OnStar. Every thread I see usually ends in "Bluetooth works great, OnStar no longer works".

Is there a VCIM that has the 3rd plug on back to accept the OnStar GPS line? I would love to stay as OEM as possible with any mods I do and want to avoid aftermarket products if I can.

I have heard "speculation" that the newer models combine both the bluetooth antenna and OnStar GPS lines into one cable. Can anyone confirm that this is in fact true? You would think someone (not me) could design a small adapter to combine the two lines to a single input.

zach2011
03-08-13, 11:23 PM
Great question as I am looking into this issue right now. I know there are lots of threads on this but I am looking for the solution where there are no issues with the OnStar. Every thread I see usually ends in "Bluetooth works great, OnStar no longer works".

Is there a VCIM that has the 3rd plug on back to accept the OnStar GPS line? I would love to stay as OEM as possible with any mods I do and want to avoid aftermarket products if I can.

I have heard "speculation" that the newer models combine both the bluetooth antenna and OnStar GPS lines into one cable. Can anyone confirm that this is in fact true? You would think someone (not me) could design a small adapter to combine the two lines to a single input.

Although my Escalade already has the Bluetooth/OnStar RemoteLink stuff I did do this to my 2008 CTS and here are the two things I noticed:


OnStar will not work properly IF you purchase a brand new VCIM. You must purchase a used one in order to have the dealer be able to program it successfully. Or, if you purchase a new one, you must have it programmed in a vehicle matching its VCIM (2010 or newer) and then swap it into your 2007-2009, and proceed to have it programmed. It is impossible to initially program/activate it to an earlier year model.
The newer roof antennas use a duplexer which does in fact route both OnStar and GPS into one cable. So you will have one cable leftover.



Now, this may be different for GMT900 VCIMs but I believe it should be somewhat if not exactly similar.

Also, there will not be a VCIM with a third antenna receptor. To gain full functionality back, assuming these vehicles use a duplexer like the CTS, you will have to order a newer antenna that has the duplexer, and possibly rerun the antenna wiring.

djredman99
03-11-13, 12:09 AM
To gain full functionality back, assuming these vehicles use a duplexer like the CTS, you will have to order a newer antenna that has the duplexer, and possibly rerun the antenna wiring.

Great idea on the new antenna install along with the VCIM. I guess I (we) need to look into what it takes to install a new-style antenna.

zach2011
03-11-13, 11:37 PM
If you can find a picture (maybe on eBay or somewhere) of a newer VCIM for these vehicles, just look and see if it has one or two antenna receptors. If one then yes, you will need a new antenna. If the antenna only has one output, then just connect one of your old cables to it and connect the other end of it to the new VCIM. You will have one unused cable not connected to anything on either end. Should be all there is to it.

blkonblk
05-25-13, 11:27 AM
Does anyone have a part # for this new antenna?

ssmith29
05-28-13, 04:00 PM
Here are the part numbers for the antenna with out Digital Audio 20849992 List Price $55.48 and with digital audio 20791465 List Price $73.00..

wesyder
05-28-13, 05:19 PM
Here are the part numbers for the antenna with out Digital Audio 20849992 List Price $55.48 and with digital audio 20791465 List Price $73.00..

Digital audio? Xm? or something else

ssmith29
05-28-13, 07:05 PM
I am not sure maybe someone else can chime in and let us know.

ssmith29
05-28-13, 09:49 PM
Speaking of questions here is one for someone, So here is my question I have an 09 Silverado with blue tooth what my goal is, is to change the VCIM to one that will now give me the option for the onstar remote link app to work as well as continue to use onstar and blue tooth my current VCIM is a 20783877 it is the one that has the three antenna connectors on it. I also have one that came from a 2013 Silverado it is part # 22898335 but it only has one antenna connector on it..Any help you can provide I would be greatful for, Thanks

blkonblk
05-29-13, 09:41 AM
Speaking of questions here is one for someone, So here is my question I have an 09 Silverado with blue tooth what my goal is, is to change the VCIM to one that will now give me the option for the onstar remote link app to work as well as continue to use onstar and blue tooth my current VCIM is a 20783877 it is the one that has the three antenna connectors on it. I also have one that came from a 2013 Silverado it is part # 22898335 but it only has one antenna connector on it..Any help you can provide I would be greatful for, Thanks

So that was what I did. I had the one with two antenna connectors (the third one is the bluetooth) and it was from a 2009 model e think. So i bought a 2011 model (one antenna connector) to try to gain the remote link. I installed it and called onstar. I was trying to get them to get my car and the vcim combined. When i was transferred to the 'technical specialist' and i asked her if the remote link would work now because i had a 2011 vcim she replied NO, she said remote link has to do with the car and not vcim,,,hmmmm i said this dumb bi..h doesnt know jack shit and hung up. So i called onstar right back and told them I am a new owner of the vehicle and would like to set up a new account (they think i'm in a 2011 tahoe now). the lady set it up, got a bunch of free minutes and three free months of onstar. I downloaded the remote link app, set up a new onstar account online and wualaaaa, remote link works. Onstar works also but i still have a redlight on my mirror,,,i believe that is because one of the antennas is not hooked up behind the new vcim. I have to find a antenna splitter (like the ones from yout tv cable) and hook up the two that are coming in and have one output. The only problem is where do I find this thing. Does anyone have any idea how we can hook this up? I know someone suggested to buy a new antenna, but that looks like a bitch to remove (headliner etc)

ssmith29
05-29-13, 10:57 AM
Which antenna did you connect to the single connector?

blkonblk
05-29-13, 11:33 AM
Which antenna did you connect to the single connector?

the purple one

----------

just found what we need,,a little pricey but what to do

https://gmspecialservicetools.spx.com/ToolDetails.aspx?id=5661

I placed an order for one,,,will let you guys know how it goes

ssmith29
05-29-13, 12:30 PM
Ok got it to work with your instructions although they think I am driving a 2013 Silverado, bonus I got 6 months free of directions and connections and 300 minutes the app works perfect I just don't know how to handle it through my ins company now they used my onstar account to give me a discount on my mileage but with the 6 months free onstar that already paid for the new vcim, please keep us updated on that new antenna deal if that fixes it I am all in on one. The new vcim has a different female voice she is a lot easier to understand and it comes through a lot clearer. But just wanted to add thanks for all of your help up to this point..

blkonblk
05-29-13, 12:57 PM
Ok got it to work with your instructions although they think I am driving a 2013 Silverado, bonus I got 6 months free of directions and connections and 300 minutes the app works perfect I just don't know how to handle it through my ins company now they used my onstar account to give me a discount on my mileage but with the 6 months free onstar that already paid for the new vcim, please keep us updated on that new antenna deal if that fixes it I am all in on one. The new vcim has a different female voice she is a lot easier to understand and it comes through a lot clearer. But just wanted to add thanks for all of your help up to this point..

im glad you got it to work, the remote link app is awesome. how did you get 6 months free?? you a better salesman then me lol

ssmith29
05-29-13, 02:11 PM
I think its because the vcim came out of a 2013 so I believe they see it as a brand new vehicle which would come with 6 months versus a used vehicle you can get 3 months free or if you have a non activated onstar account and you push the button you can also get 3 months free. I am not going to argue with them as this has already saved over $120.00 for the free 6 months...

ssmith29
05-29-13, 03:24 PM
I am guessing the missing antenna is the gps? I used my iphone to send turn by turn navigation to my truck and it sent them but could not locate my truck in the correct spot, hopefully that new thing you are buying will fix that problem

blkonblk
05-29-13, 03:30 PM
I am guessing the missing antenna is the gps? I used my iphone to send turn by turn navigation to my truck and it sent them but could not locate my truck in the correct spot, hopefully that new thing you are buying will fix that problem

yup the missing antenna is the gps, can you try to call onstar and see if they can send the directions to your car? did not work for me. hopefully when i connect everything it should work

Cadillac Cust Svc
05-29-13, 04:16 PM
Ok got it to work with your instructions although they think I am driving a 2013 Silverado, bonus I got 6 months free of directions and connections and 300 minutes the app works perfect I just don't know how to handle it through my ins company now they used my onstar account to give me a discount on my mileage but with the 6 months free onstar that already paid for the new vcim, please keep us updated on that new antenna deal if that fixes it I am all in on one. The new vcim has a different female voice she is a lot easier to understand and it comes through a lot clearer. But just wanted to add thanks for all of your help up to this point..

Hello ssmith29,

I am glad to hear other forum members were able to provide their great knowledge on your situation to assist. I am happy the voice is easier for you to understand and comes through clearer on your vehicle. Continue to enjoy, and if there is ever any questions or concerns that arise, please reach out to us!

Sincerely,

Laura M.
Cadillac Customer Service

ssmith29
05-29-13, 08:44 PM
Well I think I will hold off on another call to onstar today as I placed about 5 and talked to about 15 people, I am able to send the directions to my vehicle but it shows my vehicle somewhere other then where it is if I route my self for about a 5 or 6 mile trip it shows to be about a 14 mile trip in my vehicle so it is trying to start me from somewhere other then where I am, but I used the app to send the directions just select the nav tab at the bottom enter the address you want to go to and then send to vehicle.

OnStar Advisor
05-30-13, 09:29 AM
Well I think I will hold off on another call to onstar today as I placed about 5 and talked to about 15 people, I am able to send the directions to my vehicle but it shows my vehicle somewhere other then where it is if I route my self for about a 5 or 6 mile trip it shows to be about a 14 mile trip in my vehicle so it is trying to start me from somewhere other then where I am, but I used the app to send the directions just select the nav tab at the bottom enter the address you want to go to and then send to vehicle.

ssmith29,

I'd like to help, and review your case to see if there's anything I can do to further assist. Can you please send me a PM with you account and contact information? Thanks!

-Jessica, OnStar Advisor
Social Media Team

ssmith29
05-30-13, 03:53 PM
Help with what??? I believe the only remaining problem is because my GPS antenna isn't hooked up yet, I hope to get that corrected in a few days and hopefully all will be well.

OnStar Advisor
05-30-13, 04:15 PM
ssmith29,

Glad to hear that! Sounds like you've got everything already set up. Let me know if there is anything additional I can assist with. I'm always happy to help.

-Jessica, OnStar Advisor
Social Media Team

ssmith29
06-03-13, 04:25 PM
Well I got my diplexer thing today hooked it up and wow got a green light on* works like it should my Bluetooth works and my on* app works thanks to everyone one this forum for the help I have posted this on 10 other forums but no one was able to help except here thanks again for everything...

wesyder
06-03-13, 05:10 PM
Well I got my diplexer thing today hooked it up and wow got a green light on* works like it should my Bluetooth works and my on* app works thanks to everyone one this forum for the help I have posted this on 10 other forums but no one was able to help except here thanks again for everything...

Great.... Now somebody clean this up and tell us what to do lol

blkonblk
06-11-13, 11:10 AM
Great.... Now somebody clean this up and tell us what to do lol

What do you need help with? Where are you stuck?

wesyder
06-11-13, 11:54 AM
What do you need help with? Where are you stuck?

Im good,i havent started yet jus was looking for a parts list

burtdahurt
07-03-13, 10:16 PM
ssmith29 I am havin the same dillemma that you described.. i have 2 antenna wires and 1 plug on my vcim... could you share the part number of the diplexer/splitter that you used to turn the onstar light green !!! thanks in advance !! Robert

ssmith29
07-04-13, 12:17 PM
Hi I tried to email it to you but it said your box was full here is a link to the page as well as the part number is EL-49903-3

https://gmspecialservicetools.spx.com/ToolDetails.aspx?id=5661

christiff159
07-09-13, 12:57 AM
This is super helpful. I just ordered the diplexer splitter via the link you posted and was curious if there are step by step instructions on which cables plug into the splitter and where the splitter plugs into the VCIM. I assume the leftover GPS cable is one that plugs into the splitter but beyond that I'm not sure where everything else fits in. Suggestions?

ssmith29
07-09-13, 10:05 PM
The splitter is color coded purple blue and gray your factory purple and blue antenna goto the splitter blue and purple spots and then the splitters third leg is attached via a short jumper wire one end is gray that goes to the splitter the other end is purple that goes to your vcim hope that helps.

christiff159
08-11-13, 07:07 PM
The splitter is color coded purple blue and gray your factory purple and blue antenna goto the splitter blue and purple spots and then the splitters third leg is attached via a short jumper wire one end is gray that goes to the splitter the other end is purple that goes to your vcim hope that helps.

Great description, thanks! We plugged everything in as you listed it - but our On-Star light is still Red. Is there something else you can suggest we try?

blkonblk
08-16-13, 12:26 AM
just because its red does not mean its not working. mine is red also but everything is functional. i can send directions to my nav from my phone, i can contact onstar and they send directions directly to my nav etc. one thing to mention is that you have to have a newer nav (i installed a 2012 nav into my 2008 tahoe) for the directions to come to the nav. i did not work on my old nav. hope this helps

bigdaddyvj@aol.com
08-17-13, 07:22 PM
I have a 07 escalade no Bluetooth in like to put a 2011 vcim communication but my vcim have 4 plug wire in 2011 vcim have 3 plug wire

ssmith29
08-22-13, 05:52 PM
Your escalade has navigation correct? The vehicle that the 2011 vcim came out of did not no big deal the fourth wire is for the voice operated nav if I remember correctly I had to add that wire to my vcim when I installed a factory nav head unit,hope that helps...

pezboy
10-01-13, 06:32 PM
I am looking for the EL-49903-3 splitter so I can hook up an 11+ VCIM to a 10- vehicle. The website linked to in this thread goes nowhere. I found the parts in the picture online but I'm not sure if it is what I need or not. Any help would be appreciated.

http://i40.tinypic.com/1449u0n.jpg

computerman
10-02-13, 05:34 PM
Here's the link I used when I ordered mine last month.

https://gmspecialservicetools.service-solutions.com/ToolDetails.aspx?id=5661

mycaddi408
10-02-13, 06:03 PM
I am about to install mine, just need the Bluetooth antenna to arrive. here is my vcim and the splitter.

http://i256.photobucket.com/albums/hh169/nvcolombiano/6a9db01c-b3ea-4e32-89d2-48c0769f2e01_zpsbe2e7000.jpg (http://s256.photobucket.com/user/nvcolombiano/media/6a9db01c-b3ea-4e32-89d2-48c0769f2e01_zpsbe2e7000.jpg.html)

pezboy
10-02-13, 09:30 PM
Thanks!

mycaddi408
10-04-13, 12:13 AM
just installed the new vcim, splitter and Bluetooth antenna. everything works perfect, I have a green light. Onstar thinks that I am in a silverado and gave me 3 months free service. Dealer said that they would charge me $175 to hook up tech 2 and flash my vin on the unit. I think that is crazy!!!

mycaddi408
10-04-13, 01:49 AM
Onstar app on my iphone works too

Raven1798
10-21-13, 11:40 PM
Your escalade has navigation correct? The vehicle that the 2011 vcim came out of did not no big deal the fourth wire is for the voice operated nav if I remember correctly I had to add that wire to my vcim when I installed a factory nav head unit,hope that helps...
How did you add the wire to the vcim?

Polo_Thug
10-23-13, 06:49 PM
Trying to figure out where I can purchase A Bluetooth Compat. VCIM

pinoyfiend
10-25-13, 01:00 AM
+1^^^

bigdaddyvj@aol.com
11-21-13, 04:56 PM
How did you add the wire to the vcim? on 07 escalade

jseither1
12-11-13, 04:40 PM
mycaddi, What antenna did you use? Where did you get it from?

----------

mycaddi, what antenna did you use? Where did you get it from?

verda13
12-20-13, 02:51 PM
Will the 22737855 VCIM work WITHOUT the splitter? All I am concerned about is Bluetooth and maintaining my GPS?

verda13
12-20-13, 06:31 PM
Well, I installed it... Bluetooth works, onstar light is still green. Blue wire is not plugged it. FYI VCIM was from a 2011 GMC 2500. $105 including antenna!

gohawks
12-30-13, 10:46 PM
Well, I installed it... Bluetooth works, onstar light is still green. Blue wire is not plugged it. FYI VCIM was from a 2011 GMC 2500. $105 including antenna!If you don't mind Verda were did you get your VCIM from.
Thanks

mycaddi408
01-02-14, 02:48 PM
mycaddi, What antenna did you use? Where did you get it from?

----------

mycaddi, what antenna did you use? Where did you get it from?

I did not buy an antenna. I just bought the splitter EL-49903 from
https://gmspecialservicetools.service-solutions.com/ToolDetails.aspx?id=5661
Then I bought the VCIM from a junk yard
http://www.car-part.com/cgi-bin/search.cgi

JD2004
06-02-14, 11:17 PM
This might have been covered, but can you stream music A2DP from cellphone thru the VCIM? Also, I have a BASE EXT, no NAV/rear DVD, are there any AUX input ports in the vehicle?