: DTC Code P0442 - now what?



gunns
10-12-12, 12:04 AM
I have a code reader that came up with the following code P0442 - Evaporative Emission System Leak Detected (small leak). I've noticed lately that I have trouble filling the gas tank on any thing but slow feed. This problem is new. It wasn't always like this. If I try to fill the tank on moderate or fast speeds the pump shuts off. Don't know if this is related to the problem or not. These newer cars have so much more vacuum and vent lines I'm not sure what is the best location to start trouble shooting.

I was wondering if this problem (code P0442) is common with 2004 Eskies (6 ltr). If so what is normally the cause?

Any help is appreciated!
Thanks
Gunnar

jnrsesv
10-12-12, 01:08 AM
I would try replacing the gas cap first, its the cheapest place to start for that code.

the cadillac man
10-12-12, 01:33 AM
I have a code reader that came up with the following code P0442 - Evaporative Emission System Leak Detected (small leak). I've noticed lately that I have trouble filling the gas tank on any thing but slow feed. This problem is new. It wasn't always like this. If I try to fill the tank on moderate or fast speeds the pump shuts off. Don't know if this is related to the problem or not. These newer cars have so much more vacuum and vent lines I'm not sure what is the best location to start trouble shooting.

I was wondering if this problem (code P0442) is common with 2004 Eskies (6 ltr). If so what is normally the cause?

Any help is appreciated!
Thanks
Gunnar

I got a code like that on my 03 and it was the gas cap from what I have heard it is the seal of the o ring on the gas cap causing this because it will move out of place or fall apart due to age(mine fell apart).

I replaced the gas cap and cleared the code and so far no problems

wesyder
10-12-12, 07:54 AM
I have a code reader that came up with the following code P0442 - Evaporative Emission System Leak Detected (small leak). I've noticed lately that I have trouble filling the gas tank on any thing but slow feed. This problem is new. It wasn't always like this. If I try to fill the tank on moderate or fast speeds the pump shuts off. Don't know if this is related to the problem or not. These newer cars have so much more vacuum and vent lines I'm not sure what is the best location to start trouble shooting.

I was wondering if this problem (code P0442) is common with 2004 Eskies (6 ltr). If so what is normally the cause?

Any help is appreciated!
Thanks
Gunnar

I have no issues, however at certain gas stations i do have trouble filling the tank at high volumes, i too have to fill at slower volumes, if i use the fuel cap cable to obstruct the nozzle to filler connection to vent the vapors, it works fine but thats not exactly ideal... Just my 2 cents