: Taking a leak!



Daves_05_STS
10-02-12, 06:31 PM
Yup, every once in a while my 05 STS 3.6 78K takes a leak. This is not condensation drip off from running the AC as I've been running the heat lately. Added just over 1/2 GAL of distilled water to the overflow tank. Been doing this over the past 2-3 weeks when I first got DIC'd with the CHECK COOLANT LEVEL message. This DOES NOT HAPPEN EVERY DAY. I've run the engine while looking into the overflow tank and see zero false boils [not a head gasket issue]

Where is the water pump located on this thing? The drips are mid-car at about the firewall.
Nothing noticed at or around the radiator. I feel a decent flow when grab the return hose.

Also, the heat is hot. There is no stank or drips at the glove box area. The DIC message always disappears after running the engine for 3-4 mins or upon adding H2O. The temp gauge always sits at a hair below 1/2 way mark; never past.

Any insight greatly appreciated.

David

DarkMingBlueSTS
10-02-12, 08:01 PM
Yup, every once in a while my 05 STS 3.6 78K takes a leak. This is not condensation drip off from running the AC as I've been running the heat lately. Added just over 1/2 GAL of distilled water to the overflow tank. Been doing this over the past 2-3 weeks when I first got DIC'd with the CHECK COOLANT LEVEL message. This DOES NOT HAPPEN EVERY DAY. I've run the engine while looking into the overflow tank and see zero false boils [not a head gasket issue]

Where is the water pump located on this thing? The drips are mid-car at about the firewall.
Nothing noticed at or around the radiator. I feel a decent flow when grab the return hose.

Also, the heat is hot. There is no stank or drips at the glove box area. The DIC message always disappears after running the engine for 3-4 mins or upon adding H2O. The temp gauge always sits at a hair below 1/2 way mark; never past.

Any insight greatly appreciated.

David

How's the cabin air filter? Maybe it's getting backed up because of poor airflow...just a guess is all

EChas3
10-02-12, 09:38 PM
It does sound like a water pump.

When my V8 water pump leaked it also seemed to come from the firewall area. I think there's a panel underneath both engines for aerodynamics. Such leaks may often seem to drip from the firewall.

turnne
10-02-12, 09:40 PM
same here...water pump was leaking and was fixed under warranty about a year ago

Warren

DarkMingBlueSTS
10-02-12, 10:14 PM
When my water pump went out the leaks were on the front side of the motor(3.6)...that's where the pump is(front and in the middle of the motor)...I also noticed a "rattle" when the car warmed up a few days before the pump went out...take off the covers on the motor and inspect it, it will be easy to see if that's where the leak is coming from