: Oil pressure gauge



jlw7
10-02-12, 05:58 PM
It may be a bad gauge or something else but for the past 3 days every time I turn on my truck the oil pressure gauge just goes to 80 and stays there and then when I shut it off it goes back to 0. I haven't noticed any unusual leaks from my truck or noises. so is it just a bad gauge?

the cadillac man
10-02-12, 06:09 PM
It may be a bad gauge or something else but for the past 3 days every time I turn on my truck the oil pressure gauge just goes to 80 and stays there and then when I shut it off it goes back to 0. I haven't noticed any unusual leaks from my truck or noises. so is it just a bad gauge?

It could be a bad sender unit or gauge stepper motor.

chaztuna
10-15-12, 04:31 PM
I had similiar problem and wanted to change out sending unit myself. Problem on my 2003 is that its located at back of engine and up against firewall. Asked for anyone who had done it themselves how to approach but got zero response or help. Hope you have better results. $300.00 bill at dealership..ouch...

BillysBowties
10-16-12, 12:58 AM
Mine was doing the same thing a couple of weeks ago, then it would go to 0 then back to 80 went it would drop down my low oil pressure message would come on. I took it to my mechanic and he replaced the oil sender at the top of the motor in the back of the intake and he charged me a total of $130 and it fixed my problem. He told me when you start your engine watch the gauge and if it is real slow coming up and not just comes up pretty fast you might be looking at a oil pump replacement.