: 2000 STS Northstar coolant problems



nyukcubed
09-26-12, 11:57 AM
I just bought a 2000 STS and the previous owner said there were no issues. Ha. Whatever. The issue may be head gasket related but I'm not sure. Its pushing coolant out the overflow tank. I tested the system pressure last night and it appeared to hold pressure. I then released the pressure and started the engine. I let it warm up and the pressure went up to about 10psi. Not sure what normal is but I know the caps are rated to 15psi. The tester I was using didn't want to stay in because it was a cone shaped rubber one. The screw on fitting leaked (it didn't appear to have a gasket in it). I took the tester back and bought a new cap. This cap seemed to perform better but I still noticed a small amount of steam coming out from it and just a little leakage when I turned the car off. Any ideas? I'm holding my breath in hopes that it isn't the head but I'm ready for it if it is. I know I'm looking at at least $2500. Anything else I could do the eliminate everything else before I take the plunge? Any tests or tips? Thanks.

Submariner409
09-26-12, 12:12 PM
This ^^^ will go to a new thread titled "2000 STS Northstar coolant problems" down in the regular threads page. You'll never see much in the way of the advice you need in here.

(Moved from the "Root cause ......." sticky.)

Do some research in here on the "purge line" or Google "cadillac forums northstar coolant purge line" - enough reading will tell you why.

Simple pressure tests aren't conclusive in the head gasket failure department - and your pressure cap should be 18 psi.

Either go to a large parts store and rent (buy the fluid) a "cylinder block exhaust gas test set" or use this:

www.sjdiscounttools.com/lis75500.html (http://www.sjdiscounttools.com/lis75500.html)

Ranger
09-26-12, 03:44 PM
I took the tester back and bought a new cap. This cap seemed to perform better but I still noticed a small amount of steam coming out from it and just a little leakage when I turned the car off.
Based on that, I would not condemn the HG just yet and I think it may be a little premature for a block test. Where exactly are you seeing this steam? There should be NONE. You have a leak and thus the system can't pressurize, lowering the boiling point. Maybe a crack in the surge tank filler neck or the threads?