: climate control problem



gdegeorge
09-18-12, 11:33 PM
Just bought a used 04 Escalade ext, and am having problems. First I brought it home and gave it to my wife and she drove it around a while. She got it home and parked on our steep driveway. she sat in it running for a while and then it just died, it wouldnt even crank. The radio and interior and exerior light/radio were working fine. It just wouldnt crank. I later found out she had run out of gas, so i opened the fuze panel under the hood and discovered the PRIME fuse was fried. I read on another forum that this is normal when running out of gas to perserve the fuel pump. IS THIS RIGHT? The prime fuse is suppose to blow? I replaced the fuse and gassed it up and it runs great. So far.
Problem is now i cant use the FRONT climate control. No LED, No button control. anyone have any ideas where to start? I think i might have bought an electrical problem.

Thanks

the cadillac man
09-18-12, 11:55 PM
Just bought a used 04 Escalade ext, and am having problems. First I brought it home and gave it to my wife and she drove it around a while. She got it home and parked on our steep driveway. she sat in it running for a while and then it just died, it wouldnt even crank. The radio and interior and exerior light/radio were working fine. It just wouldnt crank. I later found out she had run out of gas, so i opened the fuze panel under the hood and discovered the PRIME fuse was fried. I read on another forum that this is normal when running out of gas to perserve the fuel pump. IS THIS RIGHT? The prime fuse is suppose to blow? I replaced the fuse and gassed it up and it runs great. So far.
Problem is now i cant use the FRONT climate control. No LED, No button control. anyone have any ideas where to start? I think i might have bought an electrical problem.

Thanks

There is a hvac 1 fuse in the dash fuse block(drivers side) and it works the front ac controls and the rear view mirror I'd say a voltage spike may have blowed the fuse replace and see if everything works