: air bag service light



cbcaddy
08-28-12, 08:38 PM
anyone else have problems with service air bag lights 06 cad sts4 awd 6 months ago had to replace passenger presence sensor in passenger seat [800.00} now have service air bag light on again but not the passenger side it still recognizes passenger,is this an on going problems for these cars any advice
Thanks

B1n2fra
08-28-12, 08:49 PM
I had the same problem I just pulled the seat forward and moved around the wires under the seat. And it was fine

caddyfat2
08-28-12, 11:54 PM
I had the same problem I just pulled the seat forward and moved around the wires under the seat. And it was fine


Me too !

C&C
08-29-12, 06:26 AM
My '06 did the same (passenger seat all the way back, intermittent light, move up or jiggle the wire connector; went out).

B1n2fra
08-29-12, 10:42 AM
I called on star and they told me it's usually the wires under the seat so I jiggled them and it went off. Plus if I pulled the seat all the way back it may sometimes come on. It's a flaw in the wires that should be addressed because it's a common issue in sts's

DitkaFan
08-29-12, 10:25 PM
Contact cleaner and dialectic grease. No issues since!

Daves_05_STS
10-02-12, 08:20 PM
My DIC never showed a SERVICE AIR BAG message until my $$$ rain-sensing windshield was replaced.
Some Vette forum suggested moving the seats back and forth. I did and the DIC went back to normal.
I can only assume the Installer[s] moved the seats around.

I found a good seating position that does not invoke the DIC message, I then set my preference to never adjust the seat at exit. No more messages.

One day I'll remove the seat and clean the connectors and yellow juice box straws of the previous Owner.

David