: STS is not starting



Gunnar Nilsson
08-19-12, 04:21 PM
Two month ago I had to tow the car to a garage as nothing happend when I pushed the starter button. They disconnected the battery and then the car worked "bug in the system". One month ago it happened again. This time I just disconnected the batteri, connected it again and all was fine. Last week I came back after vication and the car had been sitting for two weeks, didn't start. I disconnected the battery and connected it but it didn't help. I managed to start the car with the help of another battery and jumper cables. I thought it was time for a new battery (seven years) and that a weak battery might also have been the cause for the earlier problems. Gas is here 8,51 USD/gallon so it might not surprise you that I had to pay 570 Usd for a battery (it's about 200 usd for a Volvo battery here in Sweden). I installed the new fully charged battery and no! After trying several times and leaving the car without battery for an hour I finally managed to start the car. I drove home about 10 miles and stopped the car. I tried to start it again and nothing happens! All instruments and everything lights up but it don't crank. What can be wrong?
I managed to start a couple of times now but sometimes a get the message "service column lock"!

curtc
08-19-12, 09:58 PM
Does it do anything when you press the button? I just had my starter replaced under my extended warranty, all it did was click when I pressed the button...would start every 3 or 4 tries.

EChas3
08-19-12, 10:27 PM
It does sound like a bad battery. Even a new one can be bad. Have it tested under load.

Make sure the shop cleans both ends of the battery cables. That will ensure the connections are snug. I suppose it could be a starter or crank position sensor but these cars demand the best batteries.

Optoma makes a variation of the Type 78 battery that fits nicely.

DdoubleE
08-21-12, 09:38 PM
I had the same problem a few weeks ago, took it to Auto Zone and I was only getting 10.6v out of my battery. I replaced it and all is good.