: Fob not detected 2006 STS



B_n_Cat_or_Vett
07-14-12, 02:39 PM
I have been locked out of my STS twice. "Fob not detected" If I wait about ten minutes it reconize the Fob and off I go. I took the car to the dealer for repair. They look at the car and said the can't reproduce the fault. They want me to keep driving the car until it dies, and then they will know what to replace. I can't trust this car on the road. I left the car at the dealer for their supertec to look at it. Any one have this problem?

dkozloski
07-14-12, 04:00 PM
If it always happens at the same place it is probably due to electromagnetic interference from some other source. The signal from your fob is being jammed just like electronic countermeasures.

B_n_Cat_or_Vett
07-14-12, 07:22 PM
Thanks for the info dkoloski, these events happen at different places. The first time at the gas station and then at my inlaws both after a long ride. It is a bad feeling to be 300+ miles from home and you can't start your car. I have had this car six year without this problem. Where is the receiver for the Fob in the arm rest area? Maybe we had too much stuff in the arm rest area. I did have other Fobs in the arm rest because I did not want to leave them home while on my trip. We have over 70k on this car.

dkozloski
07-14-12, 08:24 PM
Change the batteries in the fobs for the next try.

Cadillac Cust Svc
07-16-12, 11:26 PM
B_n_Cat_or_Vett, I can definitely understand your frustration also suggest a battery replacement if you haven't already done so. Please feel free to email me anytime at Katie_Lucille@gmepxert.com and I can investigate further for you (follow up with the dealer, etc.)!

Looking forward to working with you,

Katie
Cadillac Customer Service

Rolex
07-16-12, 11:55 PM
:moved: to the STS forum.