: ride control MIL



max blue
06-28-12, 06:04 PM
I keep getting this error message to service the ride control. Sensors are no longer available so there is no repair, at least that's what I'm told. Dealership says that cannot disable this error message, which occupies the information screen repeatedly. Can I make it go away?

MoistCabbage
06-28-12, 07:59 PM
What code/s are triggering the message? If the problem is with the active dampers themselves, there IS a way to bypass them. What sensors is the dealer talking about?

BTW, :welcome:

D Yaros
06-30-12, 04:14 PM
There is in fact a way to disable the error message. I could not even begin to tell you how. However the good folk over on the Cad Allante forum can, and will. Go there - http://www.allante.us/cgi-bin/yabb/YaBB.pl, join and get your answer.

MoistCabbage
06-30-12, 09:32 PM
There are threads on the subject on this site, but until we know what codes are triggering the message, we can't offer a solution.

max blue
07-02-12, 04:27 PM
Thanks Moist Cabbage and D Yaros. I'll do a little more investigating and reply to this thread again.

lincor
07-03-12, 01:38 AM
I had the same issue and followed the following steps from AllanteSource:


If you wish to deactivate the Service SDD (Speed Dependent Damping) message on the Driver Information Center (DIC) message window, you can do it yourself by using the following procedure.
Four buttons on the AC control are used:
LO (fan speed) = No or skip or increment down
HI (fan speed) = Yes or select or increment up
COOLER = (Blue Button) = decrease by one for each time pressed
WARMER (Red Button) = increase by one for each time pressed
Ignition turned on, car running or not (it does not matter), press and hold the OFF and WARMER buttons on the DIC until the display changes. This is the beginning of the diagnostics mode. After the display changes, release these two buttons. Any stored trouble codes will be listed, and can be copied for future analysis. The automatic function will end at "ECM?".
At that point, press and release the LO button to skip.
At "BCM ?", press HI to select the BCM segment.
At "BCM DATA ?", press LO to skip.
At "BCM INPUTS ?", press LO to skip.
At "BCM OUTPUTS ?", press LO to skip.
At "BCM OVERRIDES?", press HI toi select.
At "BSOO No Overrides", you will need to press the HI button until you reach "BSO8 Option 2". Note down thecurrent value (probably 3) in case you want to restore it later. If you have a 1993 Allante', this value will be 11. Nortmally the new stored value should be "1" on 1989 through 1992 Allante's, and "9" on 1993 Allante's.
Press COOLER button until the number on the right is reduced by 2.
Press and hold ELAP TIME and FUEL USED buttons for at least3 seconds to save the new value in the EEPROM. The display will flash momentarily and then display the newly stored number. Press RESET to exit diagnostics or shut off the ignition.


This should work
lincor

MoistCabbage
07-03-12, 02:35 AM
Yes, if the problem is with the damper actuators, or the dampers have been replaced with passive units, ^^that^^ will disable the message.