: 2005 STS Nav issues



galvez83
06-27-12, 04:11 PM
Alright, everyone i seem to be having an issue with my sts upgraded reg radio to a nav unit. To start the scree never point north (have a gps antenna) and is never in sync with the road. I have to constantly calibrate and when i exit the menu the cursor goes back to being messed up. I have no voice and the bluetooth does not work but that doesnt bother me for now. I just to resolve this issue because its bothersome like crazy....thanx.

1BadCadSTS
06-27-12, 07:23 PM
Whatever led you to believe this was plug an play is a way wrong. Search please.

galvez83
06-27-12, 10:53 PM
I was not led to believe anything. I did the work and upgraded the nav, and the search btw was done was before i took the time to write the post.

1BadCadSTS
06-28-12, 02:11 AM
Keep trying you'll find it

EChas3
06-30-12, 12:42 AM
Chances are you've got the wrong antenna. You won't get voice guidance or Bluetooth without being a pioneer.

The VR is essentially useless, anyway, so that's no loss. A Lockpick is the way to go.

EChas3
06-30-12, 12:44 AM
Is there any aftermarket tint to your windshield? Anything metallic can intefere.

Ludacrisvp
06-30-12, 07:58 PM
The VR is essentially useless, anyway, so that's no loss.
Agreed, and annoyed. The VR in my 02 DTS was flawless with its factory Nav, the STS VR is junk.
Oh and the tint on my car made the gps signal more reliable.

1BadCadSTS
06-30-12, 08:34 PM
Without the vss wire connected the nav will never fiction period.