: iPod/iPhone Aux connection?

06-21-12, 12:05 AM
Im looking to purchase and have installed an Aux cable to recieve better sound quality rather than using the FM transmitter. Any suggestions?


06-21-12, 01:15 AM
Use the aux jacks for the rear entertainment if you have them. Assuming you don't you can look into the coastatech lockpick or iPod connector even though some people complain about sound quality. My lockpick has been fine. In your case it will sound a lot better than your fm transmitter lol. Easy 30 minute to 1 hour install as well.

06-21-12, 10:25 AM
I assume you are refering to these? I have an audio cable, but cant seem to get it to work.


06-21-12, 11:17 AM
This is what I used to plug my iPod into my system.

http://www.bestbuy.com/site/Scosche+-+showTIME+iPod+A/V+Cable/5302054.p;jsessionid=F6B5394A28724C2842A3038468D1E 92A.bbolsp-app05-39?id=1218631352793&skuId=5302054&st=ipod cable&cp=1&lp=1

06-21-12, 11:18 AM
I assume you are refering to these? I have an audio cable, but cant seem to get it to work.

<img src="http://www.cadillacforums.com/forums/attachment.php?attachmentid=93702"/>

That's what I use and then hit AUX on the screen and make sure rear is selected

06-21-12, 11:54 AM
Pretty sure thats what i did, but ill try it again. Will the kids still be able to watch the dvd in the back if i am listening to ipod upfront? Also, my cable is the one that plugs into the earphone jack of the ipod/phone, should i be using the pin connector type instead?

06-21-12, 12:37 PM
I have one of these I'm not using if your interested PM me, it's brand new but out of the package.


06-21-12, 12:54 PM
Yes plug into the white and red plugs on the rear console controls not the earphone jack as shown in the picture. You can plug the other en into the pin connector on your phone or the headphone jack in your phone depending on what cables you buy.

06-21-12, 12:58 PM
Great! Ill try it soon as I get home then let you know.

06-21-12, 04:46 PM
Tried it, and worked! The kids are able to still watch the DVD with their headphones also! Got a little static in the speakers, may just be the quality of the cable, will probably get a better one and try it. Thanks for your help!!

06-21-12, 08:39 PM
Glad to hear. There shouldn't be any static in the speakers so make sure the cables are plugged in all the way or like you said get some better cables. Either way has to be like heaven compared to the fm mod lol

06-21-12, 08:50 PM
It's your cables get a better quality and it will sound really good. Try gold connectors

06-24-12, 03:11 PM
I have used the AUX cables in the back and it a pain. I installed iPod/iphone cord. I thought it was an easy install and you can change the songs on the steering wheel and it displays the name of the song on the screen. I don't know if their is a how to install forum but if you need help pm me. Got it on ebay link below. I made him a offer of 100, 110, and 120 and he took 120.

08-06-14, 11:00 PM
Can anyone help me with a link on what cord I need to listen to my iPod through the rear aux. I'm new to electronics like this. Also this is my fort post to the thread

Actually could I get links to the modules used to connect the iPhone to the radio but retain my steering wheel controls while listening to my iPhone. Thanks.

SpyShops NY
08-06-14, 11:19 PM
ISIMPLE ISGM51 is the answer to all your problems, even Bluetooth audio turns your radio into a 2014 radio.

09-03-14, 09:13 PM
ISIMPLE ISGM51 is the answer to all your problems, even Bluetooth audio turns your radio into a 2014 radio.
I installed it and it works great. Battery died today, it has been installed for over 2 weeks. Is it draining the battery?
My solution was to install a switch or another battery. What's your take on this?
I also installed the device that disables the locking of the DVD while driving, can view back up cam in motion, and operate nav.
Any ideas as to why this battery died. After a charge I was fine.

04-24-15, 02:47 PM
Just bought 3.5mm jack to rca cable for $9.99 and connect to rear input. Work fine with iPhone 4s but no stearing control. 2007 escalade. Best and cheap solution instead of buying a new truck. Satisfied.

SpyShops NY
04-25-15, 03:29 AM
Did you get the isimple isgm 651 and the Nav TV barracuda mines does not kill my batter whatsoever maybe you need to update the firmware on the isimple or something wrong. I had both for 3 years and I been happy

04-29-15, 01:19 PM
I've had both the ISGM51 and ISGM651 both installed in my Escalade. I think the first (651) had a problem so I returned it (Amazon) and bought locally from Best Buy in case I needed to go talk with someone about it. As I understand it, both are the same thing just with different part numbers because they are sold different places. Whatever.

The ISGM51 for me works "eh." I probably would have told you it was great a month ago but I'm not so sure anymore. I had an Android phone and connected to the Bluetooth using the BT setting. Every couple minutes the audio would cut out like a record player scratching. If I put my wife's iPhone on the IPODBT Bluetooth connection, though, everything worked great. Further, if I plugged in the Aux connector to my phone physically everything worked great.

This all lasted for about 6 months. I have simply used the Aux physical connector because BT seems to suck. I assumed my Android phone was the problem and just lived with it. Then the Samsung S6 Edge came out and I was up for something new. I figured this would be a good chance to move to a phone that would work better with the iSimple device. Went to Verizon and got the phone, got in the Escalade and connected over Bluetooth to the iSimple device. About a minute later I had the audio cut out. Ugh. It did that for about 10 minutes… enough that I didn’t want to listen to it again. My wife and I went to dinner that night so we connected her iPhone again and everything worked fine. Frustrated, I thought I may just go get a fruit device and have working audio. The next morning I did exactly that… changed to an iPhone 6. Bluetooth worked great but I found that I’m just not a fruit device kinda guy so went back to Verizon for another S6 Edge. This phone also has the same problems with Bluetooth to the iSimple device.

I complained about this problem to the manufacturer when I first set everything up and they of course have never heard of such a thing. When I moved my phones around I sent them another email asking if there was anything they could do now that I’ve had 6 months or so with the iSimple device (hoping that they would have more time for a solution). Of course their response again was that they have never heard of this. Uh… yeah you did, about 6 months ago from me.

So for me the iSimple device only gets a medium rating. Works great with iPhone and on Aux but not over standard Bluetooth to my Android device.

SpyShops NY
04-30-15, 05:38 PM
I have a iPhone and I am a apple guy , I had pac before gave isimple is gm 651 a chance and I am happy with it.