: Hard Ride



avery14
06-19-12, 04:49 PM
My 2009 is riding rougher than normal. Had the tires balanced twice, lowered air pressure and still the ride is rougher than usual. Dealer gets no error codes and shows no shock or strut leakage. Anyone experienced this problem. Truck has 19000 miles on it.

BEarle
06-19-12, 05:45 PM
It's def the shocks same thing happened to me last year and it ended up being 2 shocks, the front drivers and rear passenger ( my 26s I just removed at the time for the winter months did the damage I believe )

hannity
06-19-12, 06:44 PM
I advise that you go with a softer/quieter tire. Sometimes tires have a deformity that can be noticeable many miles after purchase. Try a new set, if you still have this issue then it's something dealing with the suspension. Good luck.

Nice Ride
06-19-12, 10:56 PM
ESV? Why would you have the wheels balanced for a hard ride? If you have a vibration at speed should be the only reason for balancing, no? Any vibrations at speed? Thumping? What is the pressure of your tires? How old are they?

avery14
06-20-12, 12:43 PM
The wheels were balanced because the "hard" ride felt like a vibration or balance problem. Definitely now i realize the vibration feel is the hardness transfering the feeling. Causing a feel of vibration. The hardness is at slow and high speed. No thumping. Set tire pressure to 30, no relief. These are the original tires with 19,000 on the vehilce. I was driving the vehicle when the problem occured. One minute it was fine the next the hardness. Just dropped off this morning at another dealership. Service manager seems to have more of a clue than last one. Will advise on the outcome. Thanks.

avery14
06-20-12, 12:48 PM
I think that this is the direction a new dealer is leaning. Running stock original tires with 22's

hcvone
06-20-12, 01:17 PM
What size wheels and tires are you using?

Cadillac Cust Svc
06-20-12, 02:16 PM
The wheels were balanced because the "hard" ride felt like a vibration or balance problem. Definitely now i realize the vibration feel is the hardness transfering the feeling. Causing a feel of vibration. The hardness is at slow and high speed. No thumping. Set tire pressure to 30, no relief. These are the original tires with 19,000 on the vehilce. I was driving the vehicle when the problem occured. One minute it was fine the next the hardness. Just dropped off this morning at another dealership. Service manager seems to have more of a clue than last one. Will advise on the outcome. Thanks.

Please let us know how this dealership goes, avery! If you're still experiencing concerns after that, I'm only an email away (Katie_Lucille@gmexpert.com) and would be happy to investigate for you.

Katie
Cadillac Customer Service

avery14
06-20-12, 05:18 PM
Thank you Katie

sosoguju
06-21-12, 03:13 PM
I had the same issue with my 08 w/ factory 22s, around 22K miles the dealer said it was normal but I could def tell something was wrong. I ended up selling it and never got a resolution, wish I could be more help. Glad to hear I was not going crazy though and I am not the only one!

Nice Ride
06-21-12, 10:36 PM
Is this an Escalade ESV? Mag Shocks? You stated that it happen while you were driving, how many miles before it happen? Other things that can cause vibration, drive shaft... But not a hard ride. How much rubber left on your tires? The OEM tires are hard / high mileage tires to begin with. As they get older they will feel harder because of less rubber, and whats left just drying out and adding to the problem.

jeremyt1998
06-22-12, 02:41 AM
My 09 ESV Platinum has a very stiff ďhardĒ ride also. I donít know when it happened. When going down city streets that are little bumpier than usual you get thrown around in the vehicle especially in the rear. It feels that the rear end comes off the ground and then comes back down hard like with no shocks. If anyone has an answer that would be great. The reason I mentioned the Platinum is that they have the magnetic shocks (Mag Shocks)? Is that right?

It sounds your problems are little different than suspension problems Iím having and more of balancing problems somewhere. Did you hear back from the Dealer?

Nice Ride
06-22-12, 11:03 AM
Mag shocks are only in the front. If they have an oily film on them, they are leaking.