: Susp/ Alignment Xperts help! (rubbing sound, metal grinding sound, pulling right)



mrgoodbar67
06-13-12, 08:17 PM
so in april 2012 i replaced my stock front struts with the strutmasters conversion.
i did it myslef and wasnt hard at all. great ride now and not expensive.
3 days later, i had the alignment done (of course).
the shop was able to do it and gave me the following numbers- Everything checked out fine

Front Left Front right
Actual BEfore actual before
-1.8 -1.8 camber -1.4 -1.4
5.5 5.5 caster 5.0 5.0
.09 .35 toe .12 -.10
12.8 12.8 SAI 12.7 12.7
11.0 11.0 included angle 11.3 11.3

Front
Actual Before

Cross Camber -0.4 -0.4
Cross Caster 0.5 0.5
Cross SAI 0.1 0.1
Total Toe .21 .25

rear left rear right
actual before actual before
-0.8 -0.8 -0.8 -0.8
0.05 0.03 .10 .12

Rear
Actual Before

Cross Camber 0.0 0.0
Cross Caster 0.15 0.15
Thrust angle -0.03 -0.04

Now were in june and i have 3 issues


issue 1 -the car pulls to the right and i have to drive with the steering wheel slightly turned to the left so that the car drives straight. I figured the alignment was off again so i took it to the same guys again and gave me the following numbers-

Front Left Front right
Actual BEfore actual before
-1.2 -1.2 camber -0.4 -0.4
5.8 5.8 caster 5.2 5.2
.15 .15 toe .17 .17
12.7 12.7 SAI 13.0 13.0
11.5 11.5 included angle 12.6 12.6

Front
Actual Before
Cross Camber -0.9 -0.9
Cross Caster 0.5 0.5
Cross SAI 0.3 0.3
Total Toe .32 .32

rear left rear right
actual before actual before
-1.3 -1.3 -1.5 -1.5
0.18 0.16 .18 .18

Rear
Actual Before

Cross Camber 0.2 0.2
Cross Caster 0.36 0.34
Thrust angle 0.0 -0.01

theys said that the alignment "was with in specs" but that i needed a Camber bolt kit for the left front side because my "camber is off a whole degree". they said that was what was causing my steering to pull right. They asked if i lowered the car or hit anything after the initial alignment. i told them i had not.

issue 2- when ever i turn left like at an intersection or tight left turn, i can hear metal grinding in the right front wheel well are. ive taken the tire off and checked everything but all looks "normal".

issue 3 - there is a strange rubbing sound also coming from the right wheel well/ tire area. sounds like the tire is rubbing on something. however, i checked for clearance and all looks "normal". only occurs when im rolling in the car and not in park. as i speed up, the sound becomes more prevailant, as i roll to stop it too, starts to slow and then stops. when i do a right sweeping turn (like a freeway off ramp and the weight of the car shifts to the left) the noise stops. but when i level out the sounds comes back. a buddy drove next to me while driving to see if he saw anything rubbing or issues but he said no.

Do i really need camber bolt kit to fix my steering & stop it from pulling right?
Will it be enough to stop the leaning to the right?
Do the numbers i provided look fine like they the shop said they are?
Did the stutmasters kit install cause all or any of these issues that i did not have before?

PLEASE HELP!!!

basscatt
06-15-12, 09:33 PM
sounds like the right hub bearing is shot -

the alignment should have caught that if it is bad -

mrgoodbar67
06-20-12, 08:49 PM
it was the right hub bearing.....there was alot of play there. well its repaired now and everything is fine. thnx