: The Nav saga continues



mr69vett
06-08-12, 11:03 PM
When I purchased my 09 EXT little less than a month ago, the day I picked up the nav wouldn't seem to load. The dealer (Marquart Motors, Chippewa Falls, WI) told me they would order me a upgrade disk and have it sent to me. Alittle less than a weeke later, the disk arrived, I loaded it and reinsereted my original nav disk, same thing, I would get disk error. I posted on here and was told to eject and reinstall while driving, and low and behold it worked, not every time on the second reload, occasionally it would take 4 or 5 reloads but it would eventually come up, and opperate normally. I called the dealer back and said it was doing the same thing and they said they would send me the new nav disk. A weeke later the new nav disk arrived, loaded up same thing. Called dealer back and they said I would have to bring the vehicle back for them to check, the only problem its 3 hours away, I made arangements with my son, who took the truck in, the service manager and my son went to the truck, started up and of course it loaded on start up, drove around and shut off restarted and it worked every time. My sone stayed in that town that evening and the next day when he was going to leave and return home, of course the nav didn't load, he brought back to dealer, they checked, it did not load for them. They are ordering me a complete new nav radio unit, I will have to bring the truck back for them to install but hopefully this will be the end. I only got a 30 day warrenty on the truck when i purchased it becasue of the miles and age. So I'll be awaiting a call from them when the new unit comes in and another trip to get it installed. All I know is I'm sure glad I don't have to pay for the replacement of this unit, I'm sure it would be Ouch to the pouch!

evois
06-08-12, 11:49 PM
they replaced mine as well.

K9Caddy
06-09-12, 05:57 AM
Did they replace the unit with the newer CF unit? Just wondering if they are upgrading the old DVD drives, once they go out.

Soldier_Escalade
06-09-12, 02:32 PM
Any chance you wana get rid of one of those Nav disks they sent you....Mine is from 08 and there has been quite alot of changes in the city i live in...What year are they from ??? 2012 ??? Let me know...

Cadillac Cust Svc
06-09-12, 03:41 PM
When I purchased my 09 EXT little less than a month ago, the day I picked up the nav wouldn't seem to load. The dealer (Marquart Motors, Chippewa Falls, WI) told me they would order me a upgrade disk and have it sent to me. Alittle less than a weeke later, the disk arrived, I loaded it and reinsereted my original nav disk, same thing, I would get disk error. I posted on here and was told to eject and reinstall while driving, and low and behold it worked, not every time on the second reload, occasionally it would take 4 or 5 reloads but it would eventually come up, and opperate normally. I called the dealer back and said it was doing the same thing and they said they would send me the new nav disk. A weeke later the new nav disk arrived, loaded up same thing. Called dealer back and they said I would have to bring the vehicle back for them to check, the only problem its 3 hours away, I made arangements with my son, who took the truck in, the service manager and my son went to the truck, started up and of course it loaded on start up, drove around and shut off restarted and it worked every time. My sone stayed in that town that evening and the next day when he was going to leave and return home, of course the nav didn't load, he brought back to dealer, they checked, it did not load for them. They are ordering me a complete new nav radio unit, I will have to bring the truck back for them to install but hopefully this will be the end. I only got a 30 day warrenty on the truck when i purchased it becasue of the miles and age. So I'll be awaiting a call from them when the new unit comes in and another trip to get it installed. All I know is I'm sure glad I don't have to pay for the replacement of this unit, I'm sure it would be Ouch to the pouch!
We're happy to hear at how well this situation is turning, mr69vett, and are looking forward to hearing how everything goes!
Have a great weekend,
Sarah (Assisting Katie)
Cadillac Customer Service

mr69vett
06-18-12, 08:37 PM
Dealer called me eariler last week, said my new Nav/radioi was in, went up on friday, just over an hour and it was ready to go, they installed the new Nav disk, works like a champ! The only thing is I have to drive 3 hours to get there and 3 hours back, but it was still better than a good day at work! Was very happy with the dealer (Marquart Motors Chippewa Falls, WI) And of course they washed and vacuumed it! I did post a reply on a other Nav post .02C he said that he sent his nav unit in and for 250 had it rebuilt, and if I would have problems down the road I would definitly look onto this option, othere than replacing a how many thousand dollar head unit!

Dave

hcvone
06-19-12, 06:38 AM
Glad they fixed your problem. :)