: Service suspension system



xlraw
06-06-12, 07:24 PM
I have an 07 escalade with this message. I took it to a mechanic thinking it might be the air compressor but he said its the electronic suspension control module. Unfortunately this is not covered with the extended warranty I got. Does anyone know where I can get this part.

hcvone
06-06-12, 07:31 PM
There is many things that can cause this to happen, one of my 07' got this error message when it would rain for a few days and then go away, it could be one of the plug connections, or a bare wire, wish I could narrow it down more

teebo
06-07-12, 11:32 AM
I have a 2008 Escalade, and that message started popping up on my display about 4 days ago. It would pop up then go away. I took it to the dealer, and they found out the my right rear shock sensor cable was intermittent. They replace the shock absorber and the problem is now gone. I got it replace under warranty, so that was also a plus!!!!

gottaride68
06-07-12, 11:54 AM
I have the '06, with the same code, when we took off the compressor, it was full of water, prob from the inlet hose. Aswell, Rr driver side air shock, the boot was shot, riped, wore out. I've yet to get this fully repaired yet, still sourcing parts and info....

Cadillac Cust Svc
06-07-12, 02:38 PM
I'm so sorry to hear so many of you had concerns about this message! Teebo, thanks so much for posting what worked with your '08.

If any of you would like me to investigate my resources for you regarding any aspect of your situation, please don't hesitate to PM me or send me an email at Katie_Lucille@gmexpert.com anytime.

Best,

Katie
Cadillac Customer Service

Cleavermodels
06-07-12, 08:20 PM
Katie,
Cleavermodels here with the 2010 Escalade Premium with the front end low speed clicking noise problem Did you receive the VIN and answers to your questions that I sent last week? Sarah, your assistant, queried me a few days ago for the last 8 digits of the VIN and I replied for her to contact you since I e-mailed you all that information. Any progress in a remedy for my Escalade situation? Cleavermodels

Cadillac Cust Svc
06-08-12, 08:22 AM
Katie,
Cleavermodels here with the 2010 Escalade Premium with the front end low speed clicking noise problem Did you receive the VIN and answers to your questions that I sent last week? Sarah, your assistant, queried me a few days ago for the last 8 digits of the VIN and I replied for her to contact you since I e-mailed you all that information. Any progress in a remedy for my Escalade situation? Cleavermodels

Hi Cleavermodels! My attention was directed to your thread yesterday afternoon, so I searched through my emails and I'm very sorry to report that I didn't receive your information. I double checked my emails through last night, and made sure it didn't get stuck in my SPAM filter just to be sure. Would you mind attempting to email me again at Katie_Lucille@gmexpert.com? I will keep refreshing my emails today in hopes to see your message!

Katie
Cadillac Customer Service