: 2010 Escalade low speed clicking noise from front suspension



Cleavermodels
05-25-12, 11:09 PM
I have 2010 Escalade and since 900 miles have experienced a front clicking,clanking noise when going over a low speed bump or in a parking lot at low speed. It has had the front shock tower bushing hole widened per TSB, A body mount pad replaced by TSB, dash board apart twice, and wires repositioned several times. Back to dealer 13 times. Never have they tried to replace the magnetic ride control shock on the left. It used to be only at temps ,50 degrees. Now with 5100 miles it happens at higher temps. Very frustrted to have such an expensive vehicle sound so low rent when driving at a low speed in a parking lot! Help!! Cleavermodels

Cadillac Cust Svc
06-01-12, 10:52 AM
Good morning Cleavermodels,

I apologize for our late response - between server issues and the long weekend, we're a bit behind on getting out and about on the forum. I'm sorry to see that you have made so many trips in to your dealership for the same concern without a resolution. Have you ever worked with Customer Assistance before on this? If not, we're happy to take a look into the situation with you if you like. Please send us a private message with the last 8 digits of your VIN and we'll get started.

Regards,
Sarah (Assisting Katie)
Cadillac Customer Service

Cleavermodels
06-05-12, 09:34 PM
Sarah,
Thank you for your response. I e-mailed Katie with the complete VIN and a lot of information over last weekend. I hope you were shown this so you can get acting on my query. I appreciate Cadillac Customer Service assistance in this matter. Cleavermodels

GM-4-LIFE
06-06-12, 11:33 AM
I have the same issue with our 2012 Escalade Hybrid. At very low speeds, I hear the suspension clicking, but ONLY on the driver's side wheel. Very odd.

Cleavermodels
06-07-12, 09:26 PM
Cts-V-Twin,
What have you done with your dealer to remedy the situation? My clicking sound is only on the driver's side also. Cleavermodels

GM-4-LIFE
06-08-12, 12:18 AM
My wife uses the car non-stop, so I haven't been able to get it into the dealer for that issue. I will get it in as soon as I can or just report it when I take it in for it's first oil change.

barnes07
06-08-12, 08:02 AM
I have a 2007 escalade i'm also hearing a clicking and vibrating sound when slowing down. Is there a solution to this problem? It seems to be on the right side but i'm not receiving and codes or messages i also called onstar to see if they could diagnose the problem.

hcvone
06-08-12, 08:49 AM
Let us know what they find, I have had a dozen of these trucks, and we service them daily too and I have not heard, or had anyone bring up the issue. I have not seen a hybrid Escalade in person yet

Cadillac Cust Svc
06-08-12, 10:50 AM
CTS-V-TWIN, I hope all goes well at the dealership when you're able to go for service, and I look forward to your updates!

Cleavermodels, I posted this on another thread but I wanted to make sure I reach you, so it can't hurt to post on your original thread, too! Unfortunately, I have not received your correspondence after checking my email, and I apologize for this. Would you sending me a new email at Katie_Lucille@gmexpert.com with your information? Many thanks, and I look forward to working with you.

barnes07, I'm sorry to hear you're experiencing this as well! I'd recommend visiting a dealership if your troubleshooting attempts don't resolve your concern, and (like hcvone) I hope you'll let us know as your situation progresses.

Best,

Katie
Cadillac Customer Service

Cleavermodels
06-10-12, 11:03 PM
Katie,
I just re-e-mailed you at youe e-mail address the information of 5/31/12 you requested. It will be from Robert L. Kern, M.D. (aka cleavermodels).

Cadillac Cust Svc
06-11-12, 02:26 PM
Success! I emailed you back this morning, Robert, and thank you greatly for your patience. I know it must've been frustrating, so I appreciate you withstanding my email issues last week.

Looking forward to working with you,

Katie
Cadillac Customer Service