: transmission slipping/ not shifting need help

05-06-12, 06:31 PM
trying to get home,i am in dripping springs,texas. home is new mexico. Driving 70 mph, rpm rev up, car slows up to 40 mph no power. turned back towards town fastest it goes is 40mph, stopped car it advises me to put car in park when turned off and check engine light is on now. Anybody knows whats going on?

05-06-12, 08:44 PM
Ouch,... don't know... I hope someone here can give you decent info. It sounds like you have serious issues. If I was in your shoes, I'd get it to a dealer asap.

05-07-12, 06:23 AM
Slipping can be caused by low fluid level; do you have ATF under your now parked car.

05-07-12, 10:58 AM
car is at cadillac dealer will post what damage is. engine light came on and car kept on showing to put in park on display, when i turned it off. no fluid under car. also traction light was on

05-07-12, 04:09 PM
so battery went dead due to shifter not registering it was not in park. got that going, dealer shop did not find anything wrong! transmission shifting right, no check engine, computer did not even pick it up on history. Car is fine dealer checked fluid no burnt smell, no leaks. It did rain sunroof did leak, maybe some water somehow got in there and all it took was to dry up? Who knows all is well, maybe this will help someone. If they also have leaky sunroof! I think its time for trade in! car has less than 60,000 miles on it!

05-07-12, 04:15 PM
That is very good news!

05-09-12, 01:01 AM
I have heard that when the battery stars to go these cars can do funny things due to all of the electronics on it. I haven't had to replace a battery yet...

05-09-12, 01:14 AM
Transmission shift points? NOT!