: Rear Hatch Issue



cangolf
05-04-12, 07:43 AM
I believe that I have an issue with the rear hatch but prior to having it looked at would like to rule out operator error. The hatch works fine from the center console switch (opens/closes) and also from all the remotes. However the switch on the handle will not open it and the button on the bottom of the hatch will not close it. Rear glass is closed and that function works fine from the hatch button as well as remote. Am I missing something as in another lock/switch that I may have inadvertently set to lock. Any ideas as I would like to avoid a senior moment at the dealership? It is a base 07. thanks

murphy
05-04-12, 10:04 AM
Did you check the manual ? might find something in there. Also doors must be unlocked of course and I think there is a lock function on the overhead switch..

hcvone
05-04-12, 10:08 AM
I believe that I have an issue with the rear hatch but prior to having it looked at would like to rule out operator error. The hatch works fine from the center console switch (opens/closes) and also from all the remotes. However the switch on the handle will not open it and the button on the bottom of the hatch will not close it. Rear glass is closed and that function works fine from the hatch button as well as remote. Am I missing something as in another lock/switch that I may have inadvertently set to lock. Any ideas as I would like to avoid a senior moment at the dealership? It is a base 07. thanks

Make sure you are not pushing the rocker switch to the off position (in) , it has to be on (flat position) or the ligt gate will only work manually. When you press the release on the liftgate handle is there any noise at all? Does it open manually?

Cadillac Cust Svc
05-04-12, 03:48 PM
Glad to see so many helpful forum members already responding! In case you'd like to speak to an agent over the phone at any point in your investigation, GM of Canada Cadillac Customer Assistance is open M-F 7:30am - 11:30pm and Sat 7:30am - 6:00 EST, 1-888-446-2000.

Looking forward to your updates,

Katie
Cadillac Customer Service

cangolf
05-05-12, 08:39 AM
thanks for the suggestions, seems to be no way to open the hatch manually and is all quiet when try the handle button and also the button on the bottom of the door, guess it is time to get it looked at and glad to have rule out operator error, cheers

hcvone
05-05-12, 09:55 AM
thanks for the suggestions, seems to be no way to open the hatch manually and is all quiet when try the handle button and also the button on the bottom of the door, guess it is time to get it looked at and glad to have rule out operator error, cheers

May just be a connection issue, but probably the switch

CadX6
05-05-12, 01:00 PM
Having had this same problem with my 07 from day one - I tend to believe it's a software issue somewhere in the system. Mine would always work with the overhead switch but intermittently would refuse to work from the switch on the tailgate handle. When it acted up it wouldn't open the hatch with the power assist and when the overhead switch was in the off position, would not release the hatch manually. After a day or so it would start working again. No one could ever figure out the problem - particularly since it was so intermittent.
The 07 had the problem right up until the day I traded it for an 09 - that one works without fail :)