: Installed Airaid CAI, now coolant leak...help.

04-30-12, 11:24 PM
So I broke down and installed an Airaid CAI over the weekend. Pretty easy install. Love the sound at WOT. Even seems to pull a little harder, although it could be the placebo effect. Anyway, I woke up this morning to a puddle of coolant under the car. I can't tell where it is coming from so I dropped it off at the dealer. It's an 09 with 15,800mi. Anyone have a similar situation or coolant leak of any kind. Just curious. I'll post what the dealer finds out as soon as I know.

04-30-12, 11:35 PM
If I were you, I would check the coolant lines that follow the airaid to see if you nicked them or did not clip them back carefully out of the way. That's the only coolant passage that runs by the unit and the probable suspect if you installed it yourself.

04-30-12, 11:36 PM
Dang, if you were closer I'd even check it for you.

04-30-12, 11:37 PM
Has to be a nick in the line. Maybe at the front support where it passes the box. Best case, one of the barbs came loose while you were moving the line.

05-01-12, 08:14 AM
I developed a small leak from one of the lines for the intercooler, not the main engine cooling system. The dealer traced it back to there. Although it has stopped leaking, they are trying to pinpoint it with dye now. I have the stock airbox at the moment.

05-01-12, 11:09 AM
After reading some of your replies and re-reading the install directions, I bet it is one of the coolant lines running along the CAI. I'm going to let the dealer know today. I'm going to have the oil changed as well, so I don't look to stupid.