: Trifecta W38 Error



Michael_atDell
04-30-12, 09:46 AM
Anyone get a W38 error with Trifecta and able to recover? Please share your remedy. My CTS is immobile right now...

:-(

Wag-O-Neer
04-30-12, 11:20 AM
Not sure of the specific error code, but I had read of a very small number of Camaro's have a similar problem. I think the fix, was to do a FULL FLASH option, using the tuning interface. Something to that affect....

Have you called Jerry or Vince yet? Good luck!

Michael_atDell
04-30-12, 11:55 AM
I have done "Force Full" and "Low Speed".

Vince is out and Jerry hasn't responded.

Wag-O-Neer
04-30-12, 04:13 PM
Yikes.

So, did the laptop die, or did the cable disconnect during the flash or anything abnormal? Or, you just threw the tune on it, and got the error?

Michael_atDell
04-30-12, 04:19 PM
Neither. I was just turning on the ghost cam option since I got my new exhaust, got the error. Can't even go back to stock.

One thing I do not like is that I cannot open the log files to view them myself. I'm pretty savvy, even if it's something simple, I'm not able to tell.

Wag-O-Neer
04-30-12, 09:35 PM
Oh, so wait....

You had successfully tuned prior, and then went back in to flag the ghost cam, and retune.....and blamo?!

I had forgotten you were previously tuned.

I've never tried the ghost cam on mine. Jerry hasn't gotten back to you yet?

BNRacing
04-30-12, 09:36 PM
We're working on this. At the very least I hope to have him fixed up by tomorrow.

Michael_atDell
04-30-12, 09:38 PM
Oh, so wait....

You had successfully tuned prior, and then went back in to flag the ghost cam, and retune.....and blamo?!

I had forgotten you were previously tuned.

Yes, that's correct. Jerry is helping me out, I just took a break for food...

BNRacing
04-30-12, 09:38 PM
Oh, so wait....

You had successfully tuned prior, and then went back in to flag the ghost cam, and retune.....and blamo?!

I had forgotten you were previously tuned.


Yeah something went boom during the flash with the ghost cam. I am thinking it is something to do with his car being a 2008 and the ghost cam option being designed for 2010-2011 3.6DI cars. It's the same engine and same ECM so I thought it would work just fine. I've emailed Vince about this but he is supposed to be flying home today and will be back in the office tomorrow for sure. I'm hoping he'll get back to us tonight still.

Wag-O-Neer
04-30-12, 09:40 PM
Solid hypothesis. Sounds like you guys are on it.

BNRacing
04-30-12, 10:04 PM
Solid hypothesis. Sounds like you guys are on it.

Yeah we are going to try everything to fix it. Unfortunately this is always a possibility. It only happens to maybe 1% of customers, but it does happen. It's really hard to brick these ECMs, it's only happened to 3 out of over 600 of my customers in the years that I've been selling Trifecta tunes, so I don't think it's bricked. If it is, it can still be salvaged by sending it in to Vince and he can unlock it at his shop. The crappy part is I think Michael is staying at a hotel, who knows how far away from home. So it's definitely on my priority list to get him sorted out.


On a side note- for some odd reason this is always how it happens- someone is far from home and flashing/tinkering with the software when they manage to find a "bug" and the vehicle is disabled. I don't know why, but that's almost always the case. No one's ever stranded at home.

Wag-O-Neer
04-30-12, 10:25 PM
Always happens at the worst possible time, right?

Michael, are you anywhere near the DC area? If so, I can bring one of my cars to you in the meantime.

Let me know...

BNRacing
04-30-12, 10:43 PM
I've got Vince talking to me right now, Michael, are you around? My phone is all screwed up and I'm restoring it. If you don't post here, I'll be texting you in about 8 mins

----------

Looks like the TCM flash failed, not the ECM. Not related at all to selecting ghost cam

Michael_atDell
05-01-12, 03:33 AM
All good! Vince released a new version of EZ Flash that solved the issue. Turns out the ECM flashed fine, it was the TCM that failed, but like mention before, it wasn't the module.

Big thanks to Jerry and Vince for taking excellent care of me!

Wag-O-Neer
05-01-12, 08:06 AM
Very good!

I got an alert last night, that a new flavor of EZFlash had just been released. Figured it was your fix.

So, how's the ghost cam? ;)

Michael_atDell
05-01-12, 09:55 AM
So, how's the ghost cam? ;)

It has to be built into the custom tune file for 2008-2009.

BNRacing
05-01-12, 11:22 AM
Yeah it has to be built in to the tune for his car. I'll get him one with it built in

tinman
05-02-12, 12:10 PM
It appears you guys took good care of Michael. Always nice to see.