: Navi question



BlownEscalade
04-28-12, 12:52 PM
Hey is there anything I can do to fix this. I am on a road trip in the States. Right now in LA and my navigation seems to misfunction. It is like the navi and the actual Escalade are 1 block away from each others. It makes it difficult to drive with the navi for directions because it recalculates the directions all the time. Anyway to reset the gps location of the vehicle?

dkinder
04-28-12, 04:52 PM
Mine is doing the exact same thing, it really does make the Navi pretty much useless and I can't figure out how to correct the problem either, anyone else having these issues or know how to resolve it?

chakde
04-29-12, 06:53 PM
Do you have the GMX550. I had hat issue once I installed it but nine prior. I think if you disconnect the battery and rehook it should fix it.

BlownEscalade
04-29-12, 07:42 PM
Yeah I do have the 550. I'll have to try to disconnect the battery once I get home. No tools with me on my road trip :(

chakde
04-29-12, 09:03 PM
Yes because of this for my new Escalade I am trying the NavTV Barracuda module and it does not seem to have the lag so far. I have the 550 on my EXT and experience the same. I know the frustration the lag causes and was driving me insane.

North49
04-30-12, 07:52 AM
I had the same problem with my standard Gen6 lockpick. Then the unit stopped reading the Nav Disk and now I don't know it it is the lock-pick or the Nav unit. The dealership said to buy a new disk as they wear out. Sounded like a lame excuse. I will have to remove the lock-pick and see if there is any difference. What a PITA.