: 2007 EXT Broken valve spring (i think)



Maliburider
04-27-12, 10:13 AM
Has anyone here experienced the broken valve spring problem? If so what does it sound like, feel like etc? I have reported in here before about a noise, like a ticking noise intermittent. And you can here it out the exhaust pipe too. And the P0308 code is thrown. After some searches i did find an article about broken valve spring can happen on my motor. Does anyone have experience in this? And will the dealer fix it? I have 105k miles. Thank you in advance!

cutterman
04-27-12, 12:05 PM
P0308- cylinder 8 misfire.
Check spark plug, wire, and coil. Most likely to be one of these problems.

Maliburider
04-27-12, 12:30 PM
Have done all that already. I have the noise associated with it. Even had the broken exhaust manifold bolts replaced on #8 and #7 which were both broke and with new gaskets.

Cadillac Cust Svc
04-27-12, 01:27 PM
Maliburider,

I'm sorry to read that you're hearing these different sounds coming from your EXT. If you do decide on visiting a dealership, please let us know as we're available to assist in whatever way we can.

Kind regards,
Sarah (Assisting Katie)
Cadillac Customer Service

48Dodge
04-27-12, 01:32 PM
Have you pulled the plug wire and seen if the noise changes? If it's intermittent then probably a dying coil. I would think a valve would be a much more steady tick

Maliburider
04-30-12, 09:48 AM
So no one has experienced the broken valve spring? I thought it was more wide spread. Maybe that isnt whats wrong with mine. I was hoping someone may have experienced it and could tell me how it acted. Actually i hope no one has had to deal with it. Can a coil slowly die and not completely die. I assumed they were either good or bad?

North49
05-01-12, 11:13 AM
So no one has experienced the broken valve spring? I thought it was more wide spread. Maybe that isnt whats wrong with mine. I was hoping someone may have experienced it and could tell me how it acted. Actually i hope no one has had to deal with it. Can a coil slowly die and not completely die. I assumed they were either good or bad?

You can reset the ECM then swap the coil to #7 and see if the misfire code follows it.