: water pump leak after replacing pump/seal

04-22-12, 08:10 PM
i'm working on a friend's 97 deville 4.6 ns trying to fix a leaking water pump. i replaced the pump, pump seal, thermostat and cover gasket.

there is still water coming out of the pump. i can crawl underneath and watch the water coming from behind the pump pulley. and it's not a slow leak, either.

any ideas what could be causing it?

04-22-12, 09:07 PM
The O ring seal was not seated properly.

04-22-12, 09:19 PM
i took it back out, cleaned the groove, used a dab of rtv to hold the ring in place, and it's still leaking. i'm thinking maybe it's the water pump shaft seal

04-22-12, 09:22 PM
Shaft seals don't leak that bad even when they leak after 100,000 miles of wear. If that is the case, that's one shitty pump. What brand is it? Where did you get it?

04-22-12, 09:29 PM
it's an auto zone duralast part. i don't know what else it could be if it's not the water pump itself. i've taken apart and reassembled this four times now. still can't get the leak to stop

04-22-12, 09:31 PM
it's an auto zone duralast part.
All bets are off!

04-22-12, 09:34 PM
lol. i don't know what to do. i'm just spinning my wheels on this thing, and not making a dollar off of it.

04-22-12, 09:40 PM
Considering you have gone back and double checked your work and that it is an AutoZone Don'tlast part, I'd replace it with a quality pump. ACDELCO Part # 252707 $35 at Rockauto.

04-22-12, 09:45 PM
i suggested the same thing. problem was the lady needs her car, and she didn't want to wait for one to ship in. so she bought one from auto zone. i guess i'll just have ot tell her she'll have to wait

thanks for the input

04-22-12, 09:47 PM
Well, she got what she paid for.

Rockauto ships fast OR if she wants it NOW, go to a local dealer.

04-22-12, 10:21 PM
All bets are off!

Built to fail, Don'tlast. :histeric:

Right Ranger? :sneaky:

Go with a Delco part. :yup: