: Navigation display going nuts



desidon
04-17-12, 06:55 PM
First time I am seeing this on my 07. Display became magnified and froze. Had to restart the car and then the screen was unresponsive. Another shut down and car restart and things appear normal.
Anyone seen this? Pic attached

Ghost Deany
04-17-12, 07:08 PM
Wow never saw that. every once in a while, on start up in the morning, my nav screen gets a bunch of lines flickering through it for a second and then comes on normal.

BlownEscalade
04-17-12, 11:27 PM
My screen goes black evey once a while. But as soon as I reset the Escalade everything goes to normal.

murphy
04-18-12, 10:09 AM
Try disconnecting your battery for 10 mins then reconnect..

Cadillac Cust Svc
04-18-12, 11:28 AM
Sorry to hear that, desidon! If it persists, I would definitely recommend taking it to your Cadillac dealership for service. If you do try murphy's suggestion, please let us know how it goes.

Katie
Cadillac Customer Service

48Dodge
04-18-12, 03:06 PM
My screen goes black evey once a while. But as soon as I reset the Escalade everything goes to normal.
Mine fails to turn on at most once every other week, sometimes much longer. I have to hit the power button, it actually turns it off (time shows), then another power button press turns it back on correctly. Never had the problem before installing lockpick, but I installed it pretty soon after purchase so not sure if it's related. Murphy's suggestion is probably best for the OP's problem.

BlownEscalade
04-18-12, 11:28 PM
I had the problem from when I got it. Mine would be a black screen with the time showing on it, still had full control of everything just no screen. But like I said would fix itself once I cycled the ignition.

desidon
04-20-12, 09:15 AM
Took it to the dealer who said they had to upgrade software on the unit. So far so good.