: Rear/AUX HVAC System HELP!



nycice
04-17-12, 01:56 AM
I have a 2007 Escalade ESV with front/rear auto climate control. The rear system fan functions when manually dialed in the back and will adjust to manual speed control, but not control hot or cold as it used to (only hot or only cold no blend), but then the AUX button is pressed up front it takes over the rear system as it should but the fan defaults to high and remains on high infinitely. The fan will never slow down in the rear but the front fan will, also if you put it on 90 degrees in the rear you get heat as u should, if you put it to 89 it goes instantly cold (no heat at all even on a cold day). The temp function seems to only work then on all the way hot or all the way cold. I scanned the truck and had a code for rear passenger cabin sensor, I've checked and replaced both rear sensors and reset the system by removing the battery for 30 seconds then replacing it and letting the truck run. Both sensors are in good health giving a reading usually 22Kohm +or- voltage at both rear sensors is 4.95 What controls both rear sensors(maybe this is the issue)? Help please!

Cadillac Cust Svc
04-17-12, 09:58 AM
Welcome to the forum, nycice! Since you've already replaced both rear sensors and removed the battery and the problem persists, I recommend visiting your Cadillac dealership for a thorough diagnosis. I'm sure community members will be chiming in with helpful feedback, and please don't hesitate to email me at Katie_Lucille@gmexpert.com if you still have concerns.

Best,

Katie
Cadillac Customer Service